3

I have created a contact programmatically and also added interaction to that. After that it appeared in experience profile.

I found a button on the top right corner to anonimize the contact. I clicked that, but after clicking no contact is shown. Any help appreciated ..

5
  • can you add your code? Feb 1, 2019 at 10:13
  • var newContact = new Sitecore.XConnect.Contact(); client.AddContact(newContact);
    – Rajasekar
    Feb 1, 2019 at 10:21
  • var contactReference = new Sitecore.XConnect.ContactReference(Guid.Parse("470A74C1-092B-0000-0000-0579A2DD7A69")); var contact = client.Get(contactReference, new ExpandOptions() { FacetKeys = { "Personal" } });
    – Rajasekar
    Feb 1, 2019 at 10:21
  • if (contact != null) { // /sitecore/system/Marketing Control Panel/Taxonomies/Channel/Offline/Store/Enter store var enterStoreChannelId = Guid.Parse("{3FC61BB8-0D9F-48C7-9BBD-D739DCBBE032}"); var userAgent = "xConnectIntro Console App"; var interaction = new Interaction(contact, InteractionInitiator.Contact, enterStoreChannelId, userAgent);
    – Rajasekar
    Feb 1, 2019 at 10:23
  • var productPurchaseOutcomeId = Guid.Parse("{9016E456-95CB-42E9-AD58-997D6D77AE83}"); var outcome = new Outcome(productPurchaseOutcomeId, DateTime.UtcNow, "USD", 42.95m); interaction.Events.Add(outcome); client.AddInteraction(interaction); client.Submit();
    – Rajasekar
    Feb 1, 2019 at 10:23

1 Answer 1

7

Which version of Sitecore you are on? If you are working on Sitecore 9.x then I would suggest to follow below steps to show anonymous data to Experience profile.

Update IndexAnonymousContactData setting to true by default this is false in XConnect website.

<IndexAnonymousContactData>true</IndexAnonymousContactData>

You can find this setting into below xml files in Xconnect site-

/App_data/jobs/continuous/IndexWorker/App_data/Config/Sitecore/SearchIndexer/sc.Xdb.Collection.IndexerSettings.xml

and

/App_data/Config/sitecore/SearchIndexer/sc.Xdb.Collection.IndexerSettings.xml

I think just making these changes you would be able to see unknown user data in Experience profile.

And if you are using Sitecore 8.2 then below is the configuration.

<setting name="ContentSearch.Analytics.IndexAnonymousContacts" value="false"/>

I hope this can solve your issue but still if you are not able to see the data let me know.

3
  • 2
    Thnak you it's working for me..
    – Rajasekar
    Feb 1, 2019 at 10:11
  • 1
    @Rajasekar If this solves your issue, don't forget to mark it as the answer.
    – Trayek
    Feb 1, 2019 at 10:15
  • 1
    To add to this answer: you don't need to update the sc.Xdb.Collection.IndexerSettings.xml in the root path of xconnect (the 2nd path in answer from Yogesh). According to the Sitecore documentation, that file is not used. Link for Sitecore 9: doc.sitecore.com/developers/90/sitecore-experience-platform/en/…
    – Koen Heye
    Mar 5, 2019 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.