2

I just can't stop the "Sitecore XConnect Search Indexer" service.

Please note that I just removed everything related to XConnect from this machine. I'm trying to stop this service to be able to re-install everything.

Keep getting this error message:

Windows could not stop the Sitecore XConnect Search Indexer - Sitecore901.xconnect-IndexWorker service on Local Computer.

Error: 1061: The service cannot accept control messages at this time.
  • Are you able to change it from Automatic to Manual before attempting to stop it? – Jason St-Cyr Feb 1 at 20:17
  • 1
    Tried a reboot? Sounds like it is in a deletion state and a reboot will clear it. – Chris Auer Feb 1 at 20:44
  • 1
    @ChrisAuer please convert your last comment into an answer so that I can accept it :) – Hugo Santos Feb 2 at 0:23
3

Tried a reboot? Sounds like it is in a deletion state and a reboot will clear it.

When you delete a service and it is in state that cannot be removed, it flags it as "To be removed". And it is not until the next reboot that the cleanup job runs to delete the service.

I like to stop the service and run sc.exe delete [<ServiceName>] in PowerShell. That seems to work every time for me.

https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/sc-delete

  • 2
    TIL this sc.ex delete myservice thing, thank you for that Chris! – Hugo Santos Feb 2 at 0:32
  • Note that one way to get this problem to have is because the services control panel listing all services was open when the service was being removed. Windows likes to keep it around while you have it open, as far as I remember closing that window makes it go away, but i haven’t tried it in a long time. – eglasius Feb 5 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.