1

I am trying to install SXA 1.8.0 on Sitecore 9.1 environment (my local pc as testing) but I cannot install Sitecore Powershell Extension 4.7.2/5.0 which is required to be installed before SXA installation.

The error messages are shown as below:

ManagedPoolThread #3 16:37:48 ERROR Error installing 
items/master/sitecore/system/Settings/Rules/Definitions/Elements/PowerShell 
Experience Buttons/Chrome Type/of Type/{F5D1B95B-30D3-4738-B41E-6884517CB485}/en/1/xml
Exception: System.NullReferenceException
Message: Object reference not set to an instance of an object.
Source: Sitecore.Kernel
Location Sitecore.Data.DataProviders.Sql.SqlDataProvider.ResolvePathRec(String[] path, PathCache cache, CallContext context)
Location Sitecore.Data.DataProviders.DataProvider.ResolvePath(String itemPath, CallContext context, DataProviderCollection providers)
Location Sitecore.Nexus.Data.DataCommands.ResolvePathCommand.​‏‬‎‏‭‮‬‎‫‭‍‮‎‭‪‮‍‌‌‬‫‮(String , Database )
Location Sitecore.Data.Engines.EngineCommand`2.Execute()
Location Sitecore.Data.Managers.ItemProvider.GetItem(String itemPath, Language language, Version version, Database database, SecurityCheck securityCheck)
Location Sitecore.ContentTesting.Pipelines.ItemProvider.GetItem.GetItemUnderTestProcessor.Process(GetItemArgs args)
Location (Object , Object )
Location Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
Location Sitecore.Data.Managers.DefaultItemManager.GetItem(String itemPath, Language language, Version version, Database database, SecurityCheck securityCheck)
Location Sitecore.Data.Managers.DefaultItemManager.GetItem(String itemPath, Language language, Version version, Database database)
Location Sitecore.Data.Managers.ItemManager.GetItem(String itemPath, Language language, Version version, Database database)
Location Sitecore.Install.Items.ItemReference.GetItem()
Location Sitecore.Install.Items.ItemInstaller.GetTargetItem(ItemReference reference, Boolean& ignorePathCollision)
Location Sitecore.Install.Items.ItemInstaller.GetVersionInstallMode(PackageEntry entry, ItemReference reference, XmlVersionParser parser, ItemInstallerContext context, Boolean& removeVersions)
Location Sitecore.Install.Items.ItemInstaller.InstallEntry(PackageEntry entry)

Has anyone faced this issue before?

  • For the records only, is this instance fresh new or it already has a few modules installed? – Hugo Santos Feb 5 at 10:37
  • This instance is fresh other than a language pack (Japanese) was installed. – Tama Feb 6 at 0:45
  • Can you please double check your SQL Server version? – Hugo Santos Feb 6 at 0:46
0

It was caused by incompatibility of SQL Server version. I was using SQL Server 2016 instead of 2017. After migrating from SQL Server 2016 to 2017 (even after installing Sitecore 9.x, it fixed this issue).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.