2

After following the configuration steps of the Creative Exchange Live, I'm trying to run the gulp tasks through Visual Studio Code but it is throwing a certificate error when uploading:

[17:51:24] Starting 'watch-gulp'...

upload failed:Error: unable to verify the first certificate

I'm pointing to an HTTPS instance with self-signed certificate. Versions: Sitecore 9.1, SXA 1.8, node.js 10.15.0

1

Solved this by using

strictSSL: false

in every file upload/delete post/get because I'm using a self-signed certificate.

I changed the following files in the gulp\util folder inside the theme root folder: - requestChangeFile.js - requestChangeTemplate.js - requestDeleteFile.js

search for 'url: url' and add to the request get/post call the parameter 'strictSSL: false'. Example:

request.post({
            url: url,
            formData: formData,
            strictSSL: false 
        }, function(err, httpResponse, body) { 
          ... 
        });

I've found this solution in https://stackoverflow.com/a/41986721/1728196

"setting strictSSL to false will not force request package to validate the certificate"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.