5

Recently created a Sitecore PaaS instance associating with Solr IaaS, The Index Manager Console looks to be empty. What is wrong here !

enter image description here

4
  • 1
    If you open your /showconfig.aspx and search for the node <indexes, can you see any index on its children nodes? Feb 6, 2019 at 18:36
  • 5
    Usually it happens in case having any SOLR connectivity issue. Could you check you connection strings and try access SOLR via browser. Make sure you use SSL protocol within SOLR. Then, if SOLR accessible, check the logging tab in SOLR. If there are any records in red, it can also be a reason of your issue. Feb 6, 2019 at 19:30
  • yes, typical reason is that Sitecore cannot connect to solr or even could not connect when application was starting, if solr will start responding later Sitecore can still show empty list here (app pool restart is a solution on local environment)
    – Daniil
    Feb 7, 2019 at 12:49
  • Exact issue was SSL. I was able to connect via http, but https gave me a secure warning. The section (from file solr.in.cmd in my (folder)\solr-7.2.1\bin) didn't have the valid lines uncommented (with the correct values). (lines 102 - 111) enables SSL w/ correct cert from keystore
    – Rob Scott
    Jul 31, 2019 at 1:16

3 Answers 3

6

In my case, I'm always doing this to fix that :

  • Make sure your Sitecore configured properly for SOLR within \App_Config\Sitecore\ContentSearch
  • Check your connectionstrings for SOLR is configured properly or not
  • Access SOLR admin (with browser, make sure it's https) to check whether it's on or not
  • If it's on, check again if your configured index matches with SOLR Core Admin
  • If everything's ok, can try to recycle app pool for your site and wait a few minutes Check again from the control panel

Make sure your SOLR Server turned on first before your Sitecore sites

1

After spending essentially days trying to figure out why my Sitecore instance wasn't recognizing my Solr instance I updated my connection string to the following:

<add name="solr.search" connectionString="http://solr:8983/solr" />

Note the solr:8983 in place of localhost:8983. Be sure to test this address in your browser prior to using in your connection string file. The https vs http also matters so again be sure to test in your browser. Also, while debugging this I recommend you disable all of your custom index config files: You can do this by appending .DISABLED to the end of the file. If you have custom indexes they'd typically be located within:

  • \App_Config\Include\zz.Foundation\Search
  • \App_Config\Sitecore\ContentSearch

Good luck!

0

In my case I had a proxy configured but not run.

I use Fiddler and it was configured but the Fiddler was not run.

Before:

<system.net>
    <defaultProxy useDefaultCredentials="true" enabled="true" xdt:Transform="Insert">
        <proxy usesystemdefault="false" proxyaddress="http://127.0.0.1:8888" bypassonlocal="false" autoDetect="false"/>
    </defaultProxy>
</system.net>

After:

<!--<system.net>
    <defaultProxy useDefaultCredentials="true" enabled="true" xdt:Transform="Insert">
        <proxy usesystemdefault="false" proxyaddress="http://127.0.0.1:8888" bypassonlocal="false" autoDetect="false"/>
    </defaultProxy>
</system.net>-->

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.