2

We have setup Client Certificate Authentication with Solr using below link: https://blogs.perficientdigital.com/2018/08/01/client-certificate-authentication-with-solr/

Solr admin panel is loading without error

Our requirement is when Sitecore request for Solr access, Httpwebrequest has to authorize client certificate to access Solr, so we added patch config as mentioned in above link, we are able to authorize certificate via our pipeline but when we try to access Sitecore Indexing Manager, Indexes are not appearing. enter image description here

We did the following Steps: 1. Commented below line of code in Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config file.

<!--<solrHttpWebRequestFactory type="HttpWebAdapters.HttpWebRequestFactory, SolrNet" />-->
  1. Added Patch config file - using link: https://blogs.perficientdigital.com/2018/08/01/client-certificate-authentication-with-solr/

enter image description here

  1. Updated SSL settings in solr.in.cmd using above link
  2. As mentioned in above link: Enabled SOLR_SSL_NEED_CLIENT_AUTH to true

    set SOLR_SSL_NEED_CLIENT_AUTH=true

    set SOLR_SSL_WANT_CLIENT_AUTH=false

When we set SOLR_SSL_NEED_CLIENT_AUTH to true, Sitecore Indexes stopped appearing on Indexing Manager. The issue is with this setting enabled to true.If I tried to disable this setting to false indexes worked but it is not authorizing properly.

There is some configuration change we need to update to access "Solr SSL Need Client Authentication" in Sitecore which I am not able to find.

We use Sitecore 9.0 Update 2 with SXA 1.7.1

Any idea how to fix this issue?

closed as off-topic by Mark Cassidy Feb 12 at 6:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced or a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers. This can often be avoided by identifying and closely inspecting the shortest program necessary to reproduce the problem before posting." – Mark Cassidy
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Maybe dumb question but have you also deployed the code in GC.Foundation.Search.Solr namespace? You are referencing this code from from config but you also need to have dll built and deployed in bin folder – Peter Procházka Feb 8 at 6:58
  • Also if it's not typo, you are using wrong version of SXA. For Sitecore 9.0.2, you should use SXA 1.7.1. See more info here -> kb.sitecore.net/articles/180187 – Peter Procházka Feb 8 at 7:16
  • 1
    I have already deployed the code in bin folder, when I debug the code, I am able to get certificate name and its passing through IHttpWebRequest Create(Uri url) method but Indexes are not appearing. Yes we are using SXA 1.7.1 version its typo. – User464 Feb 8 at 10:03
  • I encountered a similar issue with 9.1. In my case, I restarted IIS and then they appeared. – Mikeyp Feb 8 at 17:07
  • Needs to verify the configuration at Sitecore and Solr schema needs to be populated. It means schema files manually needs to be copied in each Solr. After that restart the Solr. – Amit Kumar Feb 11 at 19:46
0

Is Content Search disabled?

<setting name="ContentSearch.Enabled" value="false" />

I've seen some of the Commerce installation processes update the Sitecore.ContentSearch.config file under App_config/Sitecore/ContentSearch folder and set it to "false."

In order to see the indexes in the index manager ContentSearch.Enabled setting must be set to "true"

0

Thanks for all your reply.

I found the solution. Client certificate with patch code did not work in local. I deployed same patch to Server. It worked.

Not the answer you're looking for? Browse other questions tagged or ask your own question.