0

I am upgrading from 8.1 to 9.1, and I'm switching to Solr before the actual upgrade.

I have a rather elaborate custom index configuration, and I converted it to Solr at the best of my knowledge. The configuration node mentioned in the title exists both in the default Solr configuration and in my custom one, but it's not being detected for some reason.

I used Dotpeek to see what's happening under the hood but was unable to determine what exactly is going wrong.

I am also unable to access /sitecore/admin/showconfig.aspx as the web application does not start.

Question

What is the best way to troubleshoot my configuration error? Should I perhaps use the one that comes with my Sitecore release and then gradually change it file-by-file until it matches mine, or what else?

  • 1
    I think that's the best way to it which you also mentioned: "use the one that comes with my Sitecore release and then gradually change it file-by-file until it matches mine". – Tamás Tárnok Feb 8 at 18:04
  • it seems you're missing the field readers node in Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config file. – Mohammed Syam Feb 9 at 0:34
  • 1
    Extract the App_Config folder and use beyond compare to compare your app_config with the vanilla App_Config folder. – Chris Auer Feb 9 at 4:24
  • Make sure to remove the .example or .disabled extension for the config Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config? – adarsh Feb 9 at 17:14
  • 1
    Don't forget that you can use the good and old SIM Tool to generate your fake showconfig.aspx you this page won't load. – Hugo Santos Feb 10 at 11:24
0

After replacing my entire config with the default one of my current Sitecore release, I was able to pin-point which specific file was causing the error by gradually replacing it with my own config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.