Environment details: Sitecore 9.0.2 + SXA 1.7.1

What I have done till now: I followed the steps provided at https://doc.sitecore.com/developers/sxa/17/sitecore-experience-accelerator/en/copy-and-customize-a-rendering.html

While cloning, I had selected the option to duplicate the items (datasource/view) wherever applicable. I changed the css class to 'Promo' from 'Promo-copy' to keep it in sync with rendering 'Promo'.

I am able to find the new rendering in the toolbox.

So, my rendering(PromoTest) is the duplicate of the promotion rendering. I also have a template of the same name(PromoTest) and the rendering is pointing to the new template. On this new template PromoTest, I have created an item Promo1.

I opened a partial rendering in the experience editor and added my new rendering 'PromoTest' to the 'main' placeholder.

Issue: The values in the fields of 'Item1' are not getting rendered.

Am I missing something? Or I am doing something wrong?

  • Rendering variant definition? Do you have it on your site? Is it assigned to your rendering? Check if field names match with your fields names from data source Feb 9, 2019 at 12:15
  • Did you set the datasource to the correct item?
    – Gatogordo
    Feb 9, 2019 at 12:46
  • @AlanPłócieniak: Thanks for pointing it out. I was under impression that default one will be applied even if no variant is created. Please provide your comment as the answer. So, I can accept the same. Can you please help me with one more issue? I have added this rendering to a few styles under presentation but I am not getting the styles option in experience editor. Feb 9, 2019 at 15:48
  • @Abhishek Please create a new question for styles problem. It will be easier for others to find an answer. Feb 9, 2019 at 17:16

1 Answer 1


Make sure that everything is OK with rendering variant definition.

  • check if it's present in your site,
  • check if your rendering has assigned proper variant,
  • make sure that field names in RV definition match with those from data source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.