Sitecore 8.1, never used Solr before, just switched from Lucene.

I downloaded the latest Solr and installed it using nssm. Generated self-signed certificate. Admin runs well at https://localhost:8983/solr/.

I created the core "sitecore_analytics_index" using the command

solr create -c sitecore_analytics_index

I can access it from the dashboard. I renamed "managed-schema" to "schema.xml" but I get an error in the log informing me that the core was upgraded to managed and I don't need the file, so I deleted it.

When I try to access the Sitecore shell, I get the following error:

Connection error to search provider [Solr] : Unable to connect to [https://localhost:8983/solr], Core: [sitecore_analytics_index]

which is baffling as I can access that very instance just fine. Sitecore log is empty as it cannot start.


Why I am getting this error?

  • 1
    If you open https://localhost:8983/solr/#/~cores/ can you find the core above mentioned? Is its name exactly the expected? Commented Feb 11, 2019 at 14:11
  • 1
    what version of Solr did you installed? Commented Feb 11, 2019 at 14:13
  • as far I remember Sitecore 8.1 with Solr is tricky, you need to do some other changes... Commented Feb 11, 2019 at 14:14
  • Yes, I can find it and the name is exactly as expected. I'm running Solr 7.6.0. Commented Feb 11, 2019 at 14:23
  • 1
    Just check this compatibility table kb.sitecore.net/articles/227897 This may help Commented Feb 11, 2019 at 14:27

2 Answers 2


This issue will resolve by enabling Sitecore.ContentSearch.Solr.Index.Analytics config file. Enable all the config files related to solr and disable all the lucence config files in app_config/include folder


I was trying to use Solr 7.6.0 with Sitecore 8.1. This will not work, and ended up installing Solr 4.10.x.

This solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.