0

The website is loading fine but I can see a lot of exception messages on the log files.

Those are all realted to XConnect and certificates as you can see on the below example:

Exception: System.InvalidOperationException
Message: The certificate was not found. Store: My, Location: LocalMachine, FindType: FindByThumbprint, FindValue: B6D2B200ABD73D686DA3F7AB0B8CE34E10657886, InvalidAllowed: False.
Source: Sitecore.Xdb.Common.Web
   at Sitecore.Xdb.Common.Web.CertificateHttpClientHandlerModifier.Process(HttpClientHandler handler)
   at Sitecore.Xdb.Common.Web.CommonWebApiClient`1.CreateRequestHandler()
   at Sitecore.Xdb.Common.Web.CommonWebApiClient`1.CreateClient()
   at System.Lazy`1.CreateValue()
   at System.Lazy`1.LazyInitValue()
   at Sitecore.Xdb.Common.Web.CommonWebApiClient`1.<ExecuteAsync>d__41.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Xdb.Common.Web.CommonWebApiClient`1.<ExecuteGetAsync>d__36.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.XConnect.Client.WebApi.ConfigurationWebApiClient.<Refresh>d__4.MoveNext()

Please note that I've installed another Sitecore instance (a 9.0.1 this time) on this same machine and that I had a few certificate issues during the process.

The first instance installed was working 100% before installing the second one. After the second one, the first one is getting the above-mentioned error messages.

So I'm pretty sure the current issue is somehow related to this, but I can't find the exact cause.

When I open my Windows Certificate Manager I can confirm that all certs for this given instance are still there:

enter image description here

And even the Certificate Issuer is there and still valid as well:

enter image description here

Any insight would be hugely appreciated.

  • Can you confirm that the Certificate Thumbprint is the same on the appropriate certificate? And if you open the certificate is it happy? It should have no warnings or errors at the top and the bottom that you have a private key that corresponds to this certificate. – Richard Dzien Feb 11 at 16:22
  • It looks like the root certificates are from SIF 1.x as they don't have the private key on the certificates. – Richard Dzien Feb 11 at 16:29
  • @RichardDzien I can confirm they are not the same. Good point... – Hugo Santos Feb 11 at 16:48
1

There are some bugs in SIF 1.x's certificate generation that were fixed in SIF 2.0. This meant that some of the configs from SIF 1.x caused problems with SIF 2.0 due to workarounds in the 9.0.x configs.

SIF 2.0.0 on SC 9.0.2 - "The operation is on user root store and UI is not allowed"

Has some solutions for this.

  • That could make sense, since the the Sitecore 9.1 instance was installed first using SIF 2.0 and then another Sitecore 9.0.1 instance was installed using a SIF 1.x version. – Hugo Santos Feb 11 at 16:52
  • 1
    An alternative workaround for increased SIF 1.x and 2.x compatibility is to specify a unique name for the -RootCertFileName parameter in the xconnect-createcert.json file. This will help keep them unique. – Richard Dzien Feb 11 at 17:10
  • Got it, thanks. Is there any way of replacing the certs I have instead of having to recreate from scratch my instances? – Hugo Santos Feb 11 at 17:13
  • 1
    You can create all the certs you need directly on the command line with the Invoke-NewRootCertificateTask and Invoke-NewSignedCertificateTask tasks in SIF 2.0. Then you will need to replace the certificate directly in IIS and enter the certificate thumbprints into the App_Config\ConnectionStrings.config file of the sitecore site and App_Config\AppSettings.config of the xconnect site. – Richard Dzien Feb 11 at 17:27
  • Sounds good, I'll try this and I get back here as soon as I have the result. – Hugo Santos Feb 11 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.