1

We have created similar workflow to "Sample Workflow".

We have configured Auto Publish like this:

deep=1&smart=1&related=1

Based on our knowledge this should be sufficient to publish also all related items (components).

This is however not working.

We have only Pages under workflow. Components are not under workflow.

Unfortunately, Auto publish is only publishing current item / page.

We are using Sitecore 9.1 with SXA 1.8. We are not using Publishing service.

Are we missing some settings?

  • 1
    Just my 2c but I've noticed that publish item with "publish related items" checked does not always publish all related items, even if they're in the link DB :( – Mark Gibbons Feb 12 '19 at 11:24
  • When we publish it "usual way" with Publish related items ticked, it is working. Related items are published – Peter Procházka Feb 12 '19 at 12:51
  • I tested this on SC 9.0 with SXA 1.8 and it works fine. Can be a bug on 9.1 or misconfiguration somewhere else. Maybe a silly question but have you checked that on "approve" command you have selected in "Next state" field correct workflow state (not the Sample Workflow approved state, in case you copied it from there)? – Izabela Wlodarska Feb 12 '19 at 22:25
  • Thanks for the hint @IzabelaWlodarska . Could be a bug in SC 9.1 indeed as the current item is published correctly. Just related items not. Will create support ticket and create answer here afterwards if I have some resolution. Thanks – Peter Procházka Feb 13 '19 at 5:25
  • I checked it on vanilla 9.1 and it works fine so seems like there is an issue in the configuration somewhere. – Izabela Wlodarska Feb 15 '19 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.