0

While installing Sitecore 9.1, I'm getting an error when I run Install-SitecoreConfiguration -Path C:\resourceFiles\Prerequisites.json

I ran Update-Module SitecoreInstallFramework before installing to make sure my SIF was up to date.

I'm not sure how to troubleshoot or what might be causing this. Any suggestions?

[---------------------------------------- WindowsFeatures : EnableWindowsOptionalFeature ---------------------------]
Install-SitecoreConfiguration : Enable-WindowsOptionalFeature failed. Error code = 0x800f0954
At line:1 char:1
+ Install-SitecoreConfiguration -Path C:\resourceFiles\Prerequisites.js ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:43
Enable-WindowsOptionalFeature : Enable-WindowsOptionalFeature failed. Error code = 0x800f0954
At C:\Program
Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.0.0\Public\Install-SitecoreConfiguration.ps1:641 char:25
+                         & $entry.Task.Command @paramSet | Out-Default
+                         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand
6

May have something to do with your domain / WSUS?

Try setting the following using gpedit.msc:

Computer Configuration -> Administrative Templates -> System -> Specify settings for optional component installation and component repair

Check the “Download repair content and optional features directly from Windows Uodate”

There’s also a registry key that does something similar. Was the solution on my end. Hope it helps.

| improve this answer | |
  • Thank you! I followed these instructions and ran the command again. SIF stopped for a very long time where it used to be erroring out. I minimized and forgot about it. About an hour later, it kicked back into gear and started installing the prerequisites as expected, and it completed successfully. – Andrew Feb 16 '19 at 0:06
3

There are several ways to start

  1. You could google error code (0x800f0954) and see whether you can solve it on your machine (if the problem is the same as yours - most of the results are related to .NET 3.5 installation. I am not sure if Prerequisites.js has it on the list)
  2. You could figure out which feature causes the problems on your machine and then search for a solution online.

comment/remove all features in FeatureName table in Prerequisites.js and then enable one and run the installation. Repeat with each feature until you find problematic one.

    "WindowsFeatures": {
    "Type": "EnableWindowsOptionalFeature",
    "Params": {
        "Online": true,
        "FeatureName": [
            "IIS-WebServer",
            "IIS-WebServerManagementTools",
            "IIS-ASPNET",
            "IIS-ASPNET45",
            "NetFx4Extended-ASPNET45",
            "WAS-NetFxEnvironment",
            "WAS-ProcessModel",
            "WAS-WindowsActivationService"
        ],
        "All": true
    }
}
  1. You could install everything manually.

You will find a section for that in the installation guide: 2.4.2 Manual Installation of the Prerequisites

  1. I will share this but please read before you copy/paste/execute

A long time ago, at the beginning of SIF thing, I created a script for installing prerequisites by myself on a completely new machine without anything installed. I am not sure if this gonna work but if this will help you with prerequisites installation maybe it's worth to try.

WebPI.PS - this is written by me. You can find it in powershellgallery and check source code here if you don't trust unknown modules.

Last time I tested in on a new machine was more than 1 year ago.

Use script at your own risk.

## Define parameters #########
$SqlServer = "."
$SqlAdminUser = "admin"
$SqlAdminPassword = "b"
##############################

Dism.exe /online /Enable-Feature /all /FeatureName:NetFx3
Dism.exe /online /Enable-Feature /all /FeatureName:IIS-ASPNET

Install-Module WebPI.PS
Import-Module WebPI.PS

Invoke-WebPI  /Install "/Products:UrlRewrite2,WDeploy36,DACFX,SQLDOM"

Invoke-Sqlcmd -ServerInstance $SqlServer -Username $SqlAdminUser -Password $SqlAdminPassword -Query "USE [master]"
Invoke-Sqlcmd -ServerInstance $SqlServer -Username $SqlAdminUser -Password $SqlAdminPassword -Query "sp_configure 'contained database authentication',1"
Invoke-Sqlcmd -ServerInstance $SqlServer -Username $SqlAdminUser -Password $SqlAdminPassword -Query "RECONFIGURE;"
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.