5

On one of our developers' local development environment, when he tries to create a new Sitecore package via the package designer, Sitecore shows a blank modal popup when we click "Generate ZIP":

Package Designer with blank modal

We don't see any errors in the Sitecore logs or presented on screen. The package designer works properly on other environments, including other developers' local environments. We tried recycling the app pool, resetting IIS, and rebooting the computer, but the issue persists.

Sitecore 8.0 rev 150223

11

When you get seemingly odd behavior like this, it's always a good idea to check the Network tab in Chrome Dev Tools (or Firebug in Firefox or whatever it's called in IE/Edge).

When you click the "Generate ZIP" button, the Sitecore client makes a POST request to /sitecore/shell/Applications/Tools/Installer/Designer. Because nothing was logged to the Sitecore log on the server, I suspected that the response from the server would have some clues.

In this case, the response had a HTTP status code of 200 OK, which threw me off at first. However, inspecting the actual response showed the problem:

{
    "commands": [
        {
            "command": "Alert",
            "value": "Cannot access path 'D:\\site\\web\\Data\\packages'. Please check PackagePath setting in the web.config file."
        }
    ]
}

I'm not sure why Sitecore returns a 200 OK here instead of a 500 Server Error, but that JSON clearly shows the problem in my case. This dev's local environment was missing the data\packages folder. Creating a new packages folder solved the problem (I encouraged the dev to copy a fresh Sitecore installation on top of the existing folders to ensure no other important items were missing.)

  • This was the solution to my specific problem. I encourage other answers if there are other possible causes of this behavior. – Ed Schwehm Oct 21 '16 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.