0

We have an SXA site in the Chinese Language, however we are unable to render the Browser Title in any of the pages.

This is working for other language sites except Chinese.

Following investigations done:

  1. Title is present in all the pages.The same field is used in other languages to display browser title and its working for all except China.

  2. Under Sitecore -> Page Designs: Template to Design Mapping is set to "Default".

  3. BrowserTitle.cshtml is present inside Views folder and is same across the sites.

  4. Meta Component Layout.cshtml is present in views/SXA/

  5. Under Sitecore -> Browser Title is same as all sites.

Can anyone please point out any similar issues?

3
  • Hello! - What version of SXA are you runnin g? Also, does this happen in multiple browsers? Have you tried with another Asian language - Japanese, Korean - something similar unicode wise? Last, Here is a list of known issues - where as it doesn't say anything specific about Chinese browser title, perhaps another language issue that was resolved will fix it. kb.sitecore.net/articles/196733 Feb 20, 2019 at 23:54
  • 1
    Thank you @Justin. All the browsers are not showing title. Hongkong Chinese works fine. Anyways I resolved it by having Sitecore.Context.Item.Fields["Title"] in the Layout page to have a work around. Feb 21, 2019 at 13:16
  • Thanks for posting a reply with your solution! Glad you got it worked out. Feb 21, 2019 at 16:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.