0

I installed Sitecore 9.1 using Powershell scripts and site is loading fine. All Content Editor related things are working fine. Also, installed both xConnect & xConnect.Client certificate in both Personal & Trusted root path of Current User as well as local computer. I see Xconnect site loading fine as expected.

Now when I try to open Experience Analytics it is showing below set of errors:

  • The OnlineInteractions graph cannot be displayed due to a server error. Contact you system administrator.
  • The ChannelsByVisits graph cannot be displayed due to a server error. Contact you system administrator.
  • The TopTenCampaignsByValue graph cannot be displayed due to a server error. Contact you system administrator.
  • The TopTenPatternsByValuePerVisit graph cannot be displayed due to a server error. Contact you system administrator.
  • The TopTenGoalsByConversions graph cannot be displayed due to a server error. Contact you system administrator.
  • The OnlineInteractionsByVisitsAndValuePerVisit graph cannot be displayed due to a server error. Contact you system administrator.

Also Below is the stack trace -

18624 22:48:22 ERROR [Sitecore Services]: HTTP GET
URL http://sitecore9xpo/sitecore/api/ao/aggregates/all/56649EAC3CCF4EAB88B0C74862DB862B/all?&dateGrouping=by-auto&&keyOrderBy=visits-Desc&dateFrom=20-11-2018&dateTo=17-02-2019&keyGrouping=by-key

Exception System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 172.22.218.218:8085
   at System.Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)
   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
   --- End of inner exception stack trace ---
   at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
   at System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
   --- End of inner exception stack trace ---
   at Sitecore.Xdb.Common.Web.Synchronous.SynchronousExtensions.SuspendContextLock[TResult](Func`1 taskFactory)
   at Sitecore.ExperienceAnalytics.Core.Repositories.ReferenceData.ReferenceDataSegmentReader.Get(IEnumerable`1 keys, NameValueCollection readingPreferences)
   at Sitecore.ExperienceAnalytics.Aggregation.Repositories.AggregationSegmentReader.Get(IEnumerable`1 keys, NameValueCollection readingPreferences)
   at Sitecore.ExperienceAnalytics.Api.RequestTypeResolver.GetReportSegments()
   at Sitecore.ExperienceAnalytics.Api.RequestTypeResolver.GetRequestType()
   at Sitecore.ExperienceAnalytics.Api.Http.ModelBinding.ReportQueryModelBinder.GetModelFromBindingContext(HttpActionContext actionContext, ModelBindingContext bindingContext)
   at Sitecore.ExperienceAnalytics.Api.Http.ModelBinding.ReportQueryModelBinder.BindModel(HttpActionContext actionContext, ModelBindingContext bindingContext)
   at System.Web.Http.ModelBinding.ModelBinderParameterBinding.ExecuteBindingAsync(ModelMetadataProvider metadataProvider, HttpActionContext actionContext, CancellationToken cancellationToken)
   at System.Web.Http.Controllers.HttpActionBinding.<ExecuteBindingAsyncCore>d__12.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Web.Http.Controllers.ActionFilterResult.<ExecuteAsync>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Web.Http.Filters.AuthorizationFilterAttribute.<ExecuteAuthorizationFilterAsyncCore>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Web.Http.Filters.AuthorizationFilterAttribute.<ExecuteAuthorizationFilterAsyncCore>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Web.Http.Filters.AuthorizationFilterAttribute.<ExecuteAuthorizationFilterAsyncCore>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Web.Http.Controllers.ExceptionFilterResult.<ExecuteAsync>d__6.MoveNext()

Please help me out here to solve the issue. Thanks in Advance.

Regards Rajath

5
  • Have you deployed marketing definitions? Feb 21 '19 at 5:14
  • No, i have not defined marketing definations till now. Since i am getting error in Experince Analytics Dashbord, i am trying to solve the same.
    – rajath
    Feb 21 '19 at 5:42
  • I mean have you done this doc.sitecore.com/users/82/sitecore-experience-platform/en/… Feb 21 '19 at 5:45
  • Hi Mark, Nope i am getting below exception in logs when try to deploy marketing definations. Also i have not configured Configure Session State Providers. 24672 00:36:01 ERROR Exception when executing agent aggregation/aggregator Exception: Sitecore.XConnect.XdbCollectionUnavailableException Message: An error occurred while sending the request. Source: Sitecore.Xdb.Common.Web Nested Exception Exception: System.Net.Http.HttpRequestException Message: An error occurred while sending the request. Source: mscorlib
    – rajath
    Feb 21 '19 at 6:38
  • 1
    Ok so that is your real issue. Experience analytics not working is a side effect of this issue. Please see sitecore.stackexchange.com/q/8561/1278 Feb 21 '19 at 7:36
0

Can you Check the below areas:

  1. Your xconnect site should have a proper Certificate.

  2. Ensure that your xconnect site is running in the HTTPS Protocol.

  3. Make sure that your xconnect services are running(sitecorexconnect-Indexworker,sitecorexconnect-MarketingAutomationservice). if those services are in a running state, then try to restart the services.

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 1 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.