4

I am using Sitecore 9.1.

I made a custom workflow and assigned a few actions and commands to it as the below picture shows:

enter image description here

The Default Comment Template field is set to the standard comment template, and Suppress comment is not checked.

My problem is that, whenever I accept or reject an item within this workflow, the comment popup never appears. I am using the buttons highlighted below enter image description here

I've been searching online for a while but have only found articles about wanting to hide the comment popup, but nothing about it not appearing in the first place..

Does anyone know what might be the cause of this issue?

6
  • Please make sure popups are blocked on your browser. Feb 27, 2019 at 14:39
  • @AmitabhVyas they are not blocked,i made sure Feb 27, 2019 at 14:39
  • The question should point out, Workbox is being used here - this is not Sitecore's standard workflow in play.
    – Mark Cassidy
    Feb 27, 2019 at 16:56
  • @MarkCassidy I did mention that I made a custom workflow at the beginning :) Feb 28, 2019 at 9:49
  • That has nothing to do with it :-) You're using Workbox for your approval flow, which changes things up a bit.
    – Mark Cassidy
    Feb 28, 2019 at 10:36

1 Answer 1

6

For bulk workflow operations there is a setting which decides whether the comment box should be displayed or not.

Add

<setting name="Workbox.SingleCommentForBulkOperation">
    <patch:delete />
</setting>
<setting name="Workbox.SingleCommentForBulkOperation" value="true" />

setting via a patch file to you App_Config.

The first line makes sure that if there is a setting with false already there, it will be removed.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.