1

I'm using Sitecore 9.1 and SXA 1.8

I have 2 servers, 1 for CM and 1 for CD, I created a site on the CM server and published it, but whenever I try to access that site on the CD I am routed to the default home page of "website".

I tried checking web database from the sitecore launchpad and found my content is there, so i don't think this is a publishing issue, i'm just not sure how to fix it.

Here is a screenshot of my site manager: enter image description here

I have tried multiple times to publish my whole site, or the entire sitecore node in the tree, but that didn't help, whenever I try to access my published site i get routed to the default home page of sitecore, and if i try to access a published page of mine, i get this error page as well enter image description here

apparently it's still trying to access the "website" site, although I am supposedly blocking it in my site manager.

I have been searching for hours for a solution, does anyone have any advice what the problem here could be?

Edit: Here are screenshots for my Portal site configurations from SXA site manager enter image description here enter image description here enter image description here enter image description here

  • Please update your post with the full Portal site configuration by clicking it then clicking open and screenshotting. – Mark Gibbons Mar 5 at 23:09
  • @MarkGibbons edited and updated – Mie ElMansy Mar 5 at 23:19
  • Is this an SXA site? – Michael West Mar 6 at 0:39
  • @MichaelWest yep, created under a tenant with sitecore normally – Mie ElMansy Mar 6 at 0:44
  • I see that you have already confirmed the items are there in the web database but please check whether the sitedefinition item for the portal site is also published correctly to web. If that's looking good, can you try recycling the app pool on cd server to rule out caching issue. – rajeev Mar 6 at 14:11
1

I came across this issue with SXA 1.7 on Sitecore 9.0.1. Not only was the site returning 404 on CD, it was also returning 404 on CM in Preview mode.

Some steps to try and troubleshoot:

  1. Make sure your Site is not hidden by others when in SXA Site Manager. Move up/down to resolve that or change the hostname in the Site Grouping.
  2. In SXA Site Manager click the Publish button to publish the site definitions.
  3. Do a full publish and restart IIS on CM and CD.
  4. Make sure you don't have any Alias, SXA Redirects, or IIS redirects that are interfering. A good way to check that is to use Fiddler to see if you are being redirected.
  5. Make sure your Link Databases are up to date, and then check through your Partial Designs one by one for broken links, as well as any Snippets referenced by your Partial Designs. In my case there was a broken link in a Snippet's Final Renderings. This snippet was referenced by a Partial Design making it difficult to track down. It seems SXA is very sensitive to broken links.
  • 1
    In our case, we did smart publish, later on, we discovered from the logs that one of snippet item was not published. Finally, we executed the full publish which fixed our issue. – Mrunal Brahmbhatt Jul 4 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.