0

Recently we have upgraded Sitecore from 8.1 version to 9.0.1 version. After upgrade few of the pages were not able to load and it is showing following error.

The partial view '/Areas/company/Views/PartialLayouts/SpotContainer.cshtml' was not found or no view engine supports the searched locations. The following locations were searched:
/Areas/company/Views/PartialLayouts/SpotContainer.cshtml 

I have checked Sitecore Presentation details for that page and found out that, we don't have any Rendering for Spotcontainer, however we have that as a Placeholder.

I have tried the below solution, but it didn't worked. https://stackoverflow.com/questions/29833583/sitecore-placeholdercontent-searching-in-wrong-location-for-partial-view

Could anyone help me to resolve this issue.

  • Can you add the relevant code (showing the placeholder) and your presentation details for an affected page? – Dan Sinclair Mar 6 at 12:47
  • Is this path '/Areas/company/Views/PartialLayouts/SpotContainer.cshtml' correct and partial view really exist? If no, what is the correct? It would be nice if you provide more information about your page. Similar error happens while updating Sitecore when you have "View Renderings" where path to file is without '.cshtml'. May be this article will be helpful for you. blogs.perficientdigital.com/2016/11/21/… – x3mxray Mar 6 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.