1

I have a user that has create permissions for certain folders in the media library, but when I log in as that user and right-click on the folder, all I see is the create folder option. If I click on the folder, I see the option to upload files and I can do so from that button in the right column. Why can't I see this as an option when I right-click and how would I go about getting that option available to the user?

1

Upload options are there only for the template:

/sitecore/templates/System/Media/Media folder

The options can be found under /sitecore/templates/Branches/System/Media node:

enter image description here

If you can see upload option as administrator and another user cannot see those options, there must be something with the access rights which does not allow that user to upload files.

Check Read access to /sitecore/templates/Branches/System/Media/Upload File and /sitecore/templates/Branches/System/Media/Upload File - Advanced items.

  • No, these folders all use the media library template, not the general template. What's more, when I go into the standard values for the media library folder, it includes the Upload File item as one of the Insert options, and I can see them listed when going to the insert options for the folders themselves. Something is preventing them from coming up when right-clicking on the item though. – Levi Wallach Mar 7 at 15:16
  • They do come up when I'm logged in as administrator, just not as this other user. This user has create and read access for the folder in question and read, write, rename, and delete access to all direct children of the folder. – Levi Wallach Mar 7 at 15:23
  • 1
    When you login as that user, can they read /sitecore/templates/Branches/System/Media/Upload File item? – Marek Musielak Mar 7 at 15:38
  • Ah! That was it! I had inadvertantly denied access to the branch template node for a role that that user belonged to! Good to know where that particular item resides so if this happens again I'll know where to look, thanks! – Levi Wallach Mar 7 at 15:50
  • 1
    I updated the answer. – Marek Musielak Mar 7 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.