13

After an initial Sitecore 9.1 deployment with Sitecore Managed cloud (Default installation, x-small no custom code and configuration). We notice an excessive DTU consumption on the messaging database.

I found a similar known issue with the previous version 9.0 with difference. KB point the core database.

I am wondering if someone saw this before and if those both issues are related. https://kb.sitecore.net/articles/290593

enter image description here

  • 1
    Looks like a good support ticket. Please report back when they resolve it for you if its something others can benefit from. Also - you missed one redacted name of your managed cloud instance in the screenshot. Its a good idea not to post the name. – Mark Gibbons Mar 9 at 2:12
  • Thanks Mark, Photo Updated, and there is already a support ticket in progress. I will keep you updated. – Mohamed Krimi Mar 12 at 18:34
  • Don't have a final solution yet, but Sitecore asked to disable EXM. DTU decreased to 50%. – Mohamed Krimi Apr 1 at 13:37
  • This is a known issue with a patch available here - kb.sitecore.net/articles/586131 – Wesley Lomax Oct 1 at 15:50
0

I was suffering from similar issue for SQL server for different databases. Below are the details.

Cloud Environment: Sitecore Managed Cloud XP-Small and XP-Medium

Sitecore Version: Sitecore 9.1 update 1.

Cause of the issue: By default from Sitecore Managed Cloud Team indexing strategy was set to "onPublishEndAsyncSingleInstance" in CD role.

After investigating 10 days with Sitecore support and Product services team we found that indexing strategy was set to "onPublishEndAsyncSingleInstance" which was causing excessive DTU usage. This was set for below.

  1. sitecore_web_index
  2. sitecore_fxm_web_index
  3. sitecore_marketing_asset_index_web
  4. sitecore_marketingdefinitions_web

Solution: Apart from the Patch which is mentioned in comment by Wesley Lomax, We created a patch file for setting indexing strategy to Manual for all above from CD role. As all these are getting rebuild properly from CM role.

Patch file: Patch file has below configurations. Note this has to be added only on CD role.

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <contentSearch>
      <configuration>
        <indexes>
          <index id="sitecore_web_index">
            <strategies>
              <strategy>
                <patch:delete />
              </strategy>
              <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/manual" />
            </strategies>
          </index>
          <index id="sitecore_fxm_web_index">
            <strategies>
              <strategy>
                <patch:delete />
              </strategy>
              <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/manual" />
            </strategies>
          </index>
          <index id="sitecore_marketing_asset_index_web">
            <strategies>
              <strategy>
                <patch:delete />
              </strategy>
              <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/manual" />
            </strategies>
          </index>
          <index id="sitecore_marketingdefinitions_web">
            <strategies>
              <strategy>
                <patch:delete />
              </strategy>
              <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/manual" />
            </strategies>
          </index>
        </indexes>
      </configuration>
    </contentSearch>
  </sitecore>
</configuration>

Additional changes: We added local cache setting to Azure apps.

Hope this answer will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.