1

I have 4 on premises servers. I ran PowerShell XP1 scaled script for distributed installation, I am getting a certificate issue as certificates are getting generated with computer name (system name).

I read a blog where it says we need to have 8 separate servers, is it true?

I think certificate generation has to be on "process name" working on intranet instead of computer name so that they are unique. I have tweaked the script to install separately.

I tried to compare installing it with xp1 scaled with single server, I could see all the thumbprint are same.

my query

Q1 : What tweaks do I need to make for the xp1 distributed to be installed in 4 servers to make it work?

Server Details

server 1:

  • xxx.sitecore.CM
  • xxx.sitecore.identityserver

server 2 :

  • xxx.sitecore.CD

server 3 :

  • xxx.sitecore.collection
  • xxx.sitecore.ma
  • xxx.sitecore.reporting
  • xxx.sitecore.processingEngine
  • xxx.sitecore.refdata
  • xxx.sitecore.reporting

Server 4:

  • xxx.sitecore.search
  • xxx.sitecore.rep
  • xxx.sitecore.prc

Thank you all for your time

  • Avinash, name of the certificates doesn't really matter until it is issued to the instance/role you are using it for. We dint use the certificates created during the installation. We decided the number of roles we will be creating for our topology, issued the corresponding certificates, installed on the required boxes and then proceeded with the Vanilla XP1 installation. Therefore we passed the actual Certificate and Thumbprint during the installation itself. – Amitabh Vyas Apr 18 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.