0

Have been trying to setup the sitecore docker with command below:

Import-Module Sitecore.DockerImages.Management -Force -Verbose

# Check parameters:
#-VersionsFilter ".*\\9\.0\.1 rev\. 171219\\.*sitecore-xpsingle.*\\windowsservercore-ltsc2016$" `

Invoke-SitecoreDockerImageBuild `
  -BuildRootPath "c:\\docker\\Sitecore\\docker-images\\sitecore" `
  -VersionsFilter "9.0.2 rev\. 180604*" `
  -AssetsSourcePath "c:\\Software\\Sitecore\\Repository\\" `
  -AssetsTransformPath "c:\tmp" `
  -Registry "VSWebsiteRegistry.azurecr.io" `
  -Isolation 'None' `
  -PushMode 'Never'

I keep getting the error below:

Step 14/25 : RUN & 'c:/solr/bin/solr.cmd' start -p 8983;     Expand-Archive -Path (Join-Path $env:INSTALL_TEMP '*.zip') -DestinationPath $env:INSTALL_TE
MP;     Expand-Archive -Path (Join-Path $env:INSTALL_TEMP '*Configuration files*.zip') -DestinationPath $env:INSTALL_TEMP;     Install-SitecoreConfigura
tion -Path $env:SIF_CONFIG     -SolrUrl "http://localhost:8983/solr"     -SolrRoot "c:/solr"     -SolrService "void"     -CorePrefix $env:SOLR_PREFIX   
  -Skip "StopSolr", "StartSolr";     Get-Process -Name "java" | Stop-Process -Force;
 ---> Running in 239c7b045448
Waiting up to 30 to see Solr running on port 8983
Started Solr server on port 8983. Happy searching!
[91mExpand-Archive : The path '' either does not exist or is not a valid file 
[0m[91msystem path.
At line:1 char:116
+ ... rt -p 8983; Expand-Archive -Path (Join-Path $env:INSTALL_TEMP '*.zip' ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (:String) [Expand-Archive], IOE 
[0m[91m   xception
[0m[91m    + FullyQualifiedErrorId : PathNotFound,Expand-Archive
[0m[91m 

I'm not able to figure out what I've done wrong here.

Looks like SOLR is started but the script is stuck on this step 14/25.

1

The problem here is that you've changed the VersionsFilter to VersionsFilter "9.0.2 rev\. 180604*". Inside that folder in https://github.com/Sitecore/docker-images/sitecore, it has build files for different configurations, XMScaled and XPSingle.

The default VersionsFilter (in the README) has -VersionsFilter ".*\\9\.0\.1 rev\. 171219\\.*sitecore-xpsingle.*\\windowsservercore-ltsc2016$" You can see in that filter that it specifically looks at folders with sitecore-xpsingle (i.e only the XPSingle configuration.

Therefore, you're trying to build more configurations than you probably need to.

The fix is to change it back to the original VersionsFilter I mentioned above, or, as you've said, to add the packages so that the XMScaled configuration can also be built.

0

If anyone faces this issue, make sure all these packages exists on your local repository drive:

Sitecore 9.0.2 rev. 180604 (WDP XM1 packages).zip

Sitecore 9.0.2 rev. 180604 (WDP XP0 packages).zip

Sitecore 9.0.2 rev. 180604 (WDP XPScaled packages).zip

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.