0

When I sync CRM contacts to Sitecore by running Dynamics Contacts to xConnect Sync pipeline batch, I can see contacts in Xdb.Collection SQL table, but not in Sitecore Experince Profile.

Is this because contacts don't have interactions? What could be the possible fix?

1

Yes this is a normal behavior. Your contacts are anonymous (without interactions) and anonymous contact are not indexed OOTB. To change the contact to be indexed you need to change in 2 places in xconnect:

  1. Open the xConnect Search Indexer's sc.Xdb.Collection.IndexerSettings.xml configuration file. In a default on-premise deployment, the full path is C:\path\to\xconnect\root\App_data\jobs\continuous\IndexWorker\App_data\Config\Sitecore\SearchIndexer\sc.Xdb.Collection.IndexerSettings.xml

  2. Set IndexAnonymousContactData to true as shown:

<Settings>

     <Sitecore>
        <XConnect>
     <!-- SearchIndexer role requires Collection and CollectionSearch role services -->
       <SearchIndexer>
            <Services>
           <IndexerSettings>
                <Type>Sitecore.Xdb.Collection.Indexing.IndexerSettings,
 Sitecore.Xdb.Collection</Type>
                 <LifeTime>Singleton</LifeTime>
                 <Options>
                 <IndexPIISensitiveData>false</IndexPIISensitiveData>
                 <IndexAnonymousContactData>false</IndexAnonymousContactData>
                 </Options>
             </IndexerSettings>
             <IIndexer>
                 <Type>Sitecore.Xdb.Collection.Indexing.DecoratedIndexer,
 Sitecore.Xdb.Collection</Type>
                 <As>Sitecore.Xdb.Collection.Indexing.IIndexer, Sitecore.Xdb.Collection</As>
                 <LifeTime>Singleton</LifeTime>
             </IIndexer>
             <IIndexRebuildFlow>
                 <Type>Sitecore.Xdb.Collection.Indexing.IndexRebuildFlow,
 Sitecore.Xdb.Collection</Type>
                 <As>Sitecore.Xdb.Collection.Indexing.IIndexRebuildFlow,
 Sitecore.Xdb.Collection</As>
                 <LifeTime>Singleton</LifeTime>
                 <Options>
                 <IncomingDataLagOnCompletion>0.00:00:05</IncomingDataLagOnCompletion>
                 <!--Enable ParallelizationDegree setting to override default value which is (processorCount*4)-->
                 <!--<ParallelizationDegree>16</ParallelizationDegree>-->
                 <BatchSize>1000</BatchSize>
                 </Options>
             </IIndexRebuildFlow>
             </Services>
         </SearchIndexer>
         </XConnect>
       </Sitecore>
     </Settings>
  1. Rebuild the xDB search index.

More information you can find here : https://doc.sitecore.com/developers/91/sitecore-experience-platform/en/enable-indexing-of-anonymous-contacts.html

6
  • Thanks Vlad but in my case I have already set IndexAnonymousContactData to true but still contacts are not appearing in experience profile.
    – S.Kazmi
    Mar 18 '19 at 12:04
  • can you check if you have data in xdb index? Mar 18 '19 at 12:14
  • I can see the data in xdb index but seems that only contains known contacts (created in sitecore) but don't have contacts which have come from dynamic crm, although crm contacts are synced in xdb (sql table). fyi: its sitecore 9.02
    – S.Kazmi
    Mar 18 '19 at 12:29
  • are you doing on your local machine ? Mar 18 '19 at 12:30
  • yes i am doing on local machine
    – S.Kazmi
    Mar 18 '19 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.