3

I have a Sitecore 9.1 instance in a PaaS environment in Azure. On the CM, when I try to log in to Sitecore, I get to the log in screen, I log in successfully, when it tries to redirect me back to Sitecore, it just bounces me right back to the log in screen. I see the Logout link in the top right, so I did get logged in, but I cant get into Sitecore.

Redirect hops after log in look like this:

https://mycmhost/identity/externallogin?authenticationType=SitecoreIdentityServer&ReturnUrl=%2fidentity%2fexternallogincallback%3fReturnUrl%3d%252fsitecore%252fshell%253fsc_lang%253den%26sc_site%3dshell%26authenticationSource%3dDefault&sc_site=shell

gets sent to:

https://myidentityserver/connect/authorize?client_id=etc...

THEN

https://myidentityserver/connect/authorize?client_id=etc...

gets sent to

https://myidentityserver/account/login?client_id=etc...

Not sure whats causing this post log in redirect back to the identity server.

closed as off-topic by Mark Cassidy Oct 11 at 17:04

  • This question does not appear to be about Sitecore CMS and multichannel marketing software, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Looks like the returnURL param is "sitecore/shell" in mycmhost/identity/… it supposed to be sitecore/client/Applications/Launchpad to properly launch sitecore application. is your pass instance is plain or any custom code installed? also did you check the admin page sitecore-host/sitecore/admin. – Gobinath Saminathan Mar 22 at 5:35
  • 3
    Sitecore sent me a hotfix:SC-Hotfix-308084-1 – Ethan Schofer Mar 22 at 12:49
  • Closing. Problem was hotfixed, mentioned in comments. – Mark Cassidy Oct 11 at 17:04
0

I had this same issue where multiple repeated attempts to log in were redirecting me back to the login page. I had a multi-site solution and was able to simply change domains to log in, but it didn't really solve the issue. Later I was able to solve the issue on my local developer instance using the following url

https://{SitecoreDomain}/sitecore/client/Applications/LicenseOptions/KickUser

I went to that URL thinking I had too many active sessions and had to remove some of them, but as soon as I hit that URL, instead of asking me to login or showing me a list of active sessions to kill, it took me right into the Sitecore desktop.

Subsequent attempts to log in after hitting this URL were successful. I don't know why it resolved my issue, but it's worth a shot.

Not the answer you're looking for? Browse other questions tagged or ask your own question.