8

Experience editor from content tree works fine, i.e. link:

http://[myhostname]/?sc_mode=edit&sc_itemid=%7bA072B881-5A9D-4288-A4E1-4F64CD7CFDA3%7d&sc_version=1&sc_lang=en&sc_site=[mysite]

Experience editor button form LaunchPad does not work (getting "The requested document was not found" error) I.e. link

http://[myhostname]/?sc_mode=edit&sc_resolvelanguage=1

If i remove &sc_resolvelanguage=1 from params, it works fine

Sitecore.NET 8.1 (rev. 160519)

Managed to reproduce it on several projects/environments.

Any ideas?

Update to share site config:

<site name="mysite" 
    enableTracking="true" 
    language="en" virtualFolder="/"
    physicalFolder="/" 
    rootPath="/sitecore/content/mysite" 
    hostName="[myhostname]" 
    startItem="/Home" 
    database="web" 
    domain="extranet" 
    allowDebug="true" 
    cacheHtml="true" 
    htmlCacheSize="50MB" 
    registryCacheSize="0" 
    viewStateCacheSize="0" 
    xslCacheSize="25MB" 
    filteredItemsCacheSize="10MB" 
    enablePreview="true" 
    enableWebEdit="true" 
    enableDebugger="true" 
    disableClientData="false" 
    cacheRenderingParameters="true" 
    renderingParametersCacheSize="10MB" 
    mvcArea="Public" 
    patch:source="Z.mysite.SiteDefinition.config"
/>
  • 1
    Does your installation have multiple sites? Are you coming into the Launchpad using the hostname for the site you want to edit in the experience editor? – Sergeant Sitecore Oct 24 '16 at 14:20
  • There is 1 site, Yes, getting to Launchpad using hostname of the site i want to edit. Updated issue description to include site config – lebeg Oct 24 '16 at 14:29
  • 1
    Could you try and set the Preview.ResolveSite property in the Sitecore.config file to true, if you haven't already? I've experienced that when you have more then the default provided website site, Sitecore have issues with resolving the correct site context in preview mode. – Søren Engel Oct 24 '16 at 16:03
  • 1
    @lebeg Interesting - I had a somewhat similar issue with the preview mode weren't working, in my case the preview date didn't work as expected while having the ResolveSite set to true (just like you are experiencing). Problem was related to how the query params for the current site were interpreted in the implementation. Sitecore did provide a fix for this, which might be along the lines of what you are seeing. I am however not sure if the problem is exactly the same, but there seems to be some issues with the way the preview site is resolved based on the context and the query parameters. – Søren Engel Oct 24 '16 at 19:14
  • 1
    @lebeg In terms of tracking down the 'how does this work', then I would recommend decompiling Sitecore's code, and attach it to a symbol server (using e.g. dotPeek), and try to find the culprit through debugging. Once located, file a Sitecore support ticket, since it sounds like a bug. – Søren Engel Oct 24 '16 at 19:18
9

I'll gather information from the comments and post them as a community wiki since not everyone is reading the comments and answer is always an answer.


This issue might occur if there are multiple site definitions.

Potential reasons:

  1. Accessing sites using different hostname that is defined in the site definition
  2. Preview.ResolveSite property in the Sitecore config is set to true
  3. Preview.DefaultWebsite property in the Sitecore config is set to the website you are visitinig

Suggested workaround:

  1. Remove the parameter from query string
  2. Set the value of the parameter to 0

The button is in the core database, in /sitecore/client/Applications/Launchpad/PageSettings/Buttons/ContentEditing/ExperienceEditor


There is an assumption that this might be a Sitecore bug. If you can explain the mechanism of how this parameter work please include information here.

Sitecore has confirmed this behavior as a bug.

The public reference number for it is 80705.

  • 3
    For what it's worth, I raised this issue with Sitecore Support for 8.1 Update-1 a while back, and I can confirm that it was accepted as a bug. The "fix" supplied was to remove the sc_resolvelanguage parameter, or to set it to "0". I was given a public reference number of 80705 for the issue. – Matt Oct 24 '16 at 21:26
  • @Szymon please update your answer to include feedback from Matt – lebeg Oct 25 '16 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.