1

Acccording to the Sitecore documentaion there should be a Open in Overlay check box in the Hyperlink manager. I am running Sitecore 9.1 with SXA 1.8 and I dont see this option (screenshot attached).

Does anyone know why this option is not showing in the RTE? The site is running with the Overlays option enabled. Is there any other documentation avilable supporting Overlays? I didn't find much yet.

enter image description here

1

You need to enable Overlays module on your site.

To add modules to a specific site:

In the Content Editor, right-click the tenant or site, click Scripts and click Add tenant module/Add site module.

enter image description here

In the Add module to site/tenant dialog, the missing modules are listed. Select the modules that you want to add, in your case "Overlays" and click Ok.

  • Thanks Peter, but the Overlays module is already enabled. I even created a new site which has Overlays enabled and it's the same issue there. – Deepak Sandhu Mar 25 at 9:11
0

Harsh Baid's solution https://www.harshbaid.in/2019/07/17/sitecore-sxa-open-in-overlay-checkbox-missing/ will fix this issue.

  1. Open the \\sitecore\shell\Controls\Rich Text Editor\EditorPage.aspx file
  2. Add the following attribute to the EditorPage.aspx file: ExternalDialogsPath="~/sitecore/shell/controls/rich text editor/Dialogs/"
  3. Clear browser cache

Sitecore Support reference for this fix is # 22850

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.