5

My environment scenario is the following:

  • Database server
  • CM server with CES 7 (free) installed
  • CD server

I was advised to follow the Coveo scaling guide (developers.coveo.com/display/public/SitecoreV4/Installing+Coveo+for+Sitecore+in+a+CM+or+CD+Configuration) for hooking up the CD server such that it doesn't need to be reindexed.

However, that appears to assume:

a) I have a database named "pub" from a Sitecore scaling (which I don't - I use default core, master, web)

and

b) that I have Coveo CES installed on a separate server (I don't but our database server was our QA server and has Sitecore and CES7 on it, but the end goal is to only run the databases there, not Sitecore or Coveo).

So after following the guide as best I can, I have the following issues:

  1. On CM, if I navigate to [URL]/coveo/rest, I get a 404 error. I looked this issue up and checked what was suggested, but don't see any issues that should be keeping this from working.

  2. On CD, after I set up the "switch master to web" stuff, I now get a "Precondition failed: The parameter 'p_SearchIndex' must not be null" error when I hit a page with a Sitecore component.

I'm using Sitecore 8.1 Update 1, with the 222 version of Coveo for Sitecore 4. Any advice on getting my setup tuned properly would be helpful. Thanks!

Update: my CM configs from the Coveo folder are zipped up here: https://dl.dropboxusercontent.com/u/1654372/Coveo.zip - and my ShowConfig from my CM is here: https://dl.dropboxusercontent.com/u/1654372/ShowConfig.txt

  • #1: For your /coveo/rest error, anything in the Coveo Diagnostic Page? Usually, when this endpoint fails, you see it in the diagnostic page. #2: A precondition failed could be many things, but it is usually Coveo items that are not published in the pub database. – flguillemette Oct 24 '16 at 14:42
  • 2
    If you can share your configs, it might help a bit. – ASura Oct 24 '16 at 14:51
  • 1
    Or the showconfig – Simon Langevin Oct 24 '16 at 14:57
  • 1
    I linked both the config files in a zip and the showconfig output in the question. – Ken McAndrew Oct 24 '16 at 14:59
  • Config for the CM seems fine, you see the virtual folder in IIS? – Simon Langevin Oct 24 '16 at 15:03
4

The URL of the Coveo/Rest extension is set in the Coveo.SearchProvider.Rest.config. Start by validating it.

The the site itself is in the Coveo.SearchProvider.config and should look like this:

<site patch:before="*[1]" name="coveorest" virtualFolder="/coveo/rest" physicalFolder="/coveo/rest" enableAnalytics="false" database="web" domain="extranet" />

Make sure the virtualfolder and the database are fine. Look at IIS to see if the site was added properly.

Then for your CD error, the switch master to web deletes the Coveo Master Index, if you still have a shell or a master index on your CD, make sure to disable all of this, since you should only be hitting web on the CD.

  • Okay, so the URL is actually with port 8080 involved to the search API. Hitting that straight (site:8080) gave me a "need to set up a search page" note, and hitting site:8080/coveo/rest gave me a "method not allowed" page, maybe because it can't do GET requests? The diagnostic page launched on my CM shows a 404 error for the Coveo Search REST endpoint though, but it's trying to use port 80 it seems to make that call. – Ken McAndrew Oct 24 '16 at 15:04
  • Try localhost:8080/rest/search – Simon Langevin Oct 24 '16 at 15:05
  • Yeah, that works, I get the JSON response, or if I use the server name I get the Windows authentication box. Is the diagnostic page pointed to the wrong place somehow that it's going to /coveo/rest and giving an error? – Ken McAndrew Oct 24 '16 at 15:08
  • Ok, so the issue is the local REST Endpoint coveo/rest . Can you try to browse the REST folder directly from IIS? right-click browse – Simon Langevin Oct 24 '16 at 15:11
  • If I right-click on the "rest" folder in IIS and do "manage folder > browse" I get a "requested document not found" error from Sitecore. So I know Sitecore isn't ignoring /coveo/rest which it's not supposed to. – Ken McAndrew Oct 24 '16 at 15:14
4

Ken,

  1. You do not need a db names "Pub", in your case you can substitute "web". Also this means that you do not need to setup the index for "Pub"

  2. The error on your CM indicates that there is an issue with your coveo install, since /coveo folder gets added to the web root by default.

  3. The CD error could be related to the new index you are trying to add or an invalid install.

So be careful with the switch to master in your case as you do not have pub, substitute with web and do not remove indexes for web.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.