6

We're having an issue where a user adds a component to a page, and then adds another component to the first component. But when they add the second component the page reloads and since the content wasn't saved after the first component was added neither component shows after the page reloads.

Having the content editor save between the two adds solves the issue, however I'd like to stream line the editing experience by saving the layout details when the first component is added, however I'm having trouble finding the correct pipeline to use to do that. Does anyone have experience with something like this?

4
  • Do you want to really save between the 2 adds, because then it saves everything not only presentation details. Maybe the users don't want to save it. I would suggest to investigate what's is the issue there, Did you check the log files? Or any exceptions while debuging? Oct 24, 2016 at 21:00
  • Which version of Sitecore are you using? Oct 25, 2016 at 7:08
  • I have seen something like this before; but I'm not sure if it's going to be the same issue I had, which was due to a customisation I added. Other than creation of the datasource item itself, does the process of adding the second rendering cause the creation of any other items (e.g folders during a pipeline processor)?
    – Matt
    Oct 25, 2016 at 20:06
  • Please check the placeholders are properly added in that item
    – Uma
    Jun 1, 2022 at 14:32

1 Answer 1

0

I have seen this before on older versions of Sitecore. It is recommended to save as you go. When training clients I often advise my clients to ctr+S as they go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.