1

Suddenly I'm having an issue with users who aren't admin users not seeing the media library item. They can still get to the media library via the tab the the bottom right or through the launchpad, but it used to show in the content editor tab alongside the content node, but now it's gone. No permissions have changed as far as I know and access viewer shows read access to it for the users who aren't seeing it. Did I just imagine it being there for them or did something change in my system to cause it to go away?

  • Which Sitecore version you are on Levi? – Amitabh Vyas Mar 29 '19 at 20:17
  • @AmitabhVyas 8.2 – Levi Wallach Mar 29 '19 at 20:28
3

If i understood correct, non admin users are not able to see the Media Library node under Sitecore.

enter image description here

Just check the View tab and "Entire Tree" option, if it is unchecked then the media library will not be visible to the user. If your non admin user want to see everything [whatever he has access] then the "Hidden Items" needs to be checked.

As an additional note,

If you are looking for the "Media Library" left bottom between "Content Editor" and "Workbox" then check the security of the item "/sitecore/content/Applications/Content Editor/Applications/MediaLibraryForm" in core DB. [this is the one displayed there]

If you are looking for the "Media Library" in the start menu left side then check the security of the item "/sitecore/content/Documents and settings/All users/Start menu/Left/Media Library" in core DB [this is the one displayed there]

  • 1
    Thanks! I don't know how that got unchecked, as I normally always have it checked, but checking entire tree did it. – Levi Wallach Mar 30 '19 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.