1

SXA Version: 1.8 Component: Maps

I am using SXA map component on my page and is connecting to Google Map. I have provided the coordinates.

I want to display the map zoomed to the street level. But irrespective of the value selected from drop-down for zoom, the map on my page is not that detailed. Though the value selected a zoom level gets updated in the source. Please see the present situation on my page. enter image description here

Any suggestion will be useful.

3
  • What APIs do you have enabled from Google maps API? – Peter Procházka Apr 3 '19 at 14:54
  • Can you validate the list of APIs with list from my blog post -> tothecore.sk/2018/09/07/… ? – Peter Procházka Apr 3 '19 at 14:56
  • 1
    @PeterProcházka: Thanks for pointing in the right direction. We also did something like you. :) We enabled al the APIs using *. – NutsAndBolts Apr 5 '19 at 6:04
1

Google changed their Maps API in June 2018 significantly and now you need to have API key generated with services enabled which was not needed before.

Steps to fix your issue:

  1. Navigate to https://console.cloud.google.com/google/maps-apis/new?project=project_name where project_name is name of your project
  2. You should see something similar: enter image description here
  3. Enabled all APIs, with "API" at the end of their name + Places API for Web by hitting "Enable" button: enter image description here
  4. You should see something like this at the end: enter image description here
  5. That's all you need to do

Check https://tothecore.sk/2018/09/07/sitecore-sxa-set-google-maps-for-map-component-with-latest-pricing-changes for further details

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.