1

I am getting 'There are no forms to display' message in Sitecore 9 Forms Dashboard in Production environment

enter image description here

In chrome developer tools, getting below error message in Console tab with below error message on clicking 403 item

{"message":"An error has occurred.","exceptionMessage":"The required anti-forgery form field \"__RequestVerificationToken\" is not present.","exceptionType":"System.Web.Mvc.HttpAntiForgeryException","stackTrace":"   at System.Web.Helpers.AntiXsrf.TokenValidator.ValidateTokens(HttpContextBase httpContext, IIdentity identity, AntiForgeryToken sessionToken, AntiForgeryToken fieldToken)\r\n   at System.Web.Helpers.AntiXsrf.AntiForgeryWorker.Validate(HttpContextBase httpContext)\r\n   at Sitecore.Web.Http.Filters.ValidateHttpAntiForgeryTokenAttribute.OnAuthorization(HttpActionContext actionContext)"}

enter image description here

  • Have you tried to rebuild indexes? – Swati Gupta Apr 9 at 12:23
1

You have couple of options how to solve this issues.

1. Not touching your Sitecore installation.

1a. You need to use Firefox instead as there was a change in one of past versions of Chrome on how it handles XHR headers which is causing trouble.

1b. Downgrade Chrome

2. Touching your Sitecore installation.

2a. Other options are upgrading to Sitecore 9.1 - where this issue is definetely solved

2b. Or possibly waiting for Sitecore 9.0 Update 3 - where this issue might be solved

For further details take a look on my blog post with similar error in Marketing Automation: https://tothecore.sk/2018/03/22/marketing-automation-not-working-in-sitecore-9-update-1-with-chrome-64/

  • Thanks for the update Peter. I have tried in firefox as well as Chrome but no luck. – Manideep Yechuri Apr 4 at 6:50
  • I am trying to get reports of each form. Is there any other way we can export the data to CSV apart from downloading from Forms Dashboard (using powershell)? – Manideep Yechuri Apr 4 at 6:51
-1

Navigate to control panel -> Indexing manager and rebuild indexes.

It is an existing bug in sitecore 9, rebuilding master and web indexes through indexing manager resolves the issue

  • 1
    How about some context as to why? – Chris Auer Apr 25 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.