1

I'm trying to install Sitecore 9 Update 1 but getting the following error:

[---------------------------------------------- InstallWDP : WebDeploy -----------------------------------------------]
[WebDeploy]:[Path] C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe
Info: Adding MsDeploy.Site (MsDeploy.Site).
Info: Adding database (user id=sa;data source=INBASDLP05243;initial catalog=sc901demo_Processing.Pools)
Info: Initializing deployment: Pending.
Info: Analyzing deployment plan: Pending.
Info: Updating database: Pending.
Info: Creating deployment plan: Pending.
Info: Verifying deployment plan: Pending.
Info: Deploying package to database: Pending.
Info: Creating deployment plan: Running.
Info: Initializing deployment: Running.
Info: Initializing deployment (Start)
Info: Initializing deployment: Faulted.
Info: Initializing deployment (Failed)
Info: Creating deployment plan: Faulted.
Info: Verifying deployment plan: Faulted.
Info: Deploying package to database: Faulted.
Error: Could not read schema model header information from package.
Error Code: ERROR_EXECUTING_METHODError: The model version '2.9' is not supported.

Error count: 1.
More Information: Could not read schema model header information from package.
The model version '2.9' is not supported.
  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_EXECUTING_METHOD.
Install-SitecoreConfiguration : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero
exit code - (-1)
At D:\SITECORE9\Sitecore901install.ps1:42 char:1
+ Install-SitecoreConfiguration @xconnectParams
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:22
Transcript stopped, output file is D:\SITECORE9\xconnect-xp0.190405.log
Invoke-CommandTask : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero exit code -
(-1)
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\1.2.1\Public\Tasks\Invoke-WebDeployTask.ps1:36
char:2
+     Invoke-CommandTask -Path $Path -Arguments $msdeployArgs -TaskName ...
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-CommandTask

WebDeploy Error

I have used SIF 1.2.1 to install Sitecore 9.0.1. Not sure why this error is appearing or i have missed something. If somebody could help me on this it will be very helpful since i'm not able to find any clue on this.

0

It seems that you did not install required "Microsoft SQL Server Data-Tier Application Framework (DAC Fx)" version 2016.

You can download it from here: https://www.microsoft.com/enus/download/details.aspx?id=53013

See chapter "Prerequisites for using the Sitecore Installation Framework" of installation guide for more information.

  • Hi, Thanks for your reply. But i have installed the DACFx 2016 in my machine. But still getting below error. I'm not able to attach screenshot in comments and full error message. Warning: A project which specifies SQL Server 2016 as the target platform may experience compatibility issues with SQL Server 2012.Warning: The database containment option has been changed to None. This may result in deployment failure if the state of the database is not compliant with this containment level. Error: .Net SqlClient Data Provider:You can only create a user with a password in a contained database. – Vijayarajan Apr 8 at 11:11
  • 1
    Do you have SQL Server 2012? As I know It is not supported on sitecore 9. Just upgrade it and make sure to complete all of prerequisites before installation (data-tier, script dom, contained database etc.). – x3mxray Apr 9 at 14:26
  • It requires SQL 2016 Service Pack 1, ODBC Driver 13 for SQL Server, and Microsoft Command Line Utilities 13 for Sql Server. Make sure all those are installed. – andyp May 6 at 4:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.