1

I am using Sitecore 9.1 and I want to configure the Media Item save behavior. I want to save all Media Items in File Systems instead of Database. As of now i want to store in the same server.

I have enabled the Media.UploadAsFiles to true as <setting name="Media.UploadAsFiles" value="true" />

and DisableFileMedia is false by default as <setting name="Media.DisableFileMedia" value="false" />

But still i am not getting the Checkbox to select and upload the Media Item as File.

Please refer the screenshot as

  • 2
    Did you try to actually upload an asset and test where it goes? – Gatogordo Apr 8 '19 at 15:50
  • Its storing in Database,not in file system. – G. Ali Ansari Apr 9 '19 at 2:44
  • Don't undo my edits. We do not include Sitecore version information in question titles. – Mark Cassidy Apr 9 '19 at 9:15
  • @G.AliAnsari - how did you find the media item in the DB? What table/how'd you get the Id to put in WHERE? – Don Cheadle Sep 30 '19 at 21:35
2

This is expected behaviour.

You have configured upload as <setting name="Media.UploadAsFiles" value="true" /> and you expect to see all four options during upload like this:

enter image description here

This is false assumption.

As you have configured it to always upload media files to file system, there won't be anymore Upload as files option.

Do not forget to conclude your setup by specifying Media.FileFolder path. Uploaded files will be stored in this folder <setting name=”Media.FileFolder” value=”/App_Data/MediaFiles”>

| improve this answer | |
  • I have tested after changing the path also. But its not showing. – G. Ali Ansari Apr 9 '19 at 2:44
  • It is not showing because you set <setting name="Media.UploadAsFiles" value="true" /> ! Set <setting name="Media.UploadAsFiles" value="false" /> and then you will see that checkbox. – Peter Procházka Apr 9 '19 at 5:15
  • @G.AliAnsari - in other words... Media.UploadAsFiles=true is basically saying that it will always be a file anyway, so why both showing the checkbox? If you want the checkbox, change it to false so users have the choice. – Don Cheadle Sep 30 '19 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.