1

When we try to add the Security Setting to the site for the first time we are able to run the Setup Security script with the link under Scripts.

When we tried to make changes again in the security, unfortunately the Setup Security option is no longer available. How can we get the Setup Security option back to make changes?

enter image description here

Thank you in advance.

  • There is no reversible function to remove security once setup AFAIK. You need to create new tenant and site and set security once again on them. What specifically you are trying to achieve by setting security again? Do you want to change role names or domain? – Peter Procházka Apr 9 '19 at 6:47
  • Thanks Peter for the quick response. We would like to change access permission for the site roles. – rajender patel Apr 9 '19 at 8:05
1

Your tenant and site item will have a field called Role domain (in the Security section). If you clear that field, the script will be available again on that item.

Be aware though that clearing that field will not remove any security (as far as I know). So the security settings created by the first run will remain and you might get some strange effects if you run it again. In order to remove everything you would need to remove all the created roles as well.

I would advice you to think about what you are trying to achieve and see if you really need to start over or just change permissions on your roles (which you can do without re-running the script). It might be a good idea anyway to create roles on top of the ones that SXA created (that's what I do) and use those for extra security settings.

| improve this answer | |
  • Thank you Gatogordo your solution worked for us. – rajender patel Apr 9 '19 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.