3

Sitecore 9.1.1 Install Error

I have been able to successfully install Sitecore 9.1 and 9.1.1 previously, for some reason yesterday this error seemed to crop up somehow when attempting a fresh 9.1.1 install and now seemingly nothing I try will fix it. I'm trying to think if there's anything I did at all in the past 2 days that could have caused this, but there's nothing that comes to mind.

Here's what I have attempted so far based on another solution with a similar problem.

  • Restart OS
  • Stop Sitecore Marketing Automation Engine and Sitecore XConnect Search Indexer services & end any corresponding processes.
  • Manually delete the created users from the following databases _Processing.Pools; _MarketingAutomation; _ReferenceData. Each database has its own user: poolsuser, marketing automation user, referencedatauser (I have been making a new instance name every time anyway, so I don't think this should matter)
  • Checked Solr SSL was turned on
  • Checked event viewer, I get this Error: The World Wide Web Publishing Service (WWW Service) did not register the URL prefix https://DELETESitecoreTest5.identityserver.local:443/ for site 12. The site has been disabled. The data field contains the error number.
  • Closed Skype
  • Re-run the Powershell installation script

EDIT: Further information & attempts

  • Attempted to run my Sitecore 9.1 installation, this also faces the same issue.
  • Reinstalled Solr 7.2.1
  • Reinstalled Sitecore Install Framework 2.1.0
  • Looking through the Event Viewer, I noticed the error which I have displayed below, the APPID corresponds to the "RunTimeBroker" in Component Services, but I can't seem to change the permissions of it. I think maybe this isn't entirely relevant as there have been no changes to user policy and it worked perfectly before, but I thought it would be worth including here just in case. enter image description here
  • Ending COM Surrogate processes

Current Issue Status: Fixed - see answer below.

Any help is greatly appreciated, thank you!

  • Try to disable any antivirus for the duration if you have one running. I've seen similar issues with those. – morten.engel Apr 12 at 12:15
  • Hi Morten, thank you. We have a company wide anti-virus that unfortunately we cannot turn off, I had the guys look into the possibility of it interfering with what I was trying to do, but as we could not find anything that indicated a link and it had been working fine for me previously whilst also currently working for others it made sense that the issue probably was to do with something else. – Jack Hayward Apr 12 at 12:18
  • Have you tried to go to Resource Monitor on the CPU tab, and search for the filename in Associated Handles? If you find it there, at least you know which process is locking the file. – morten.engel Apr 12 at 12:44
  • I've had a look for several keywords which might point me to the file, but can't see anything that links to it, I've tried "Sitecore", "Install", "Framework" – Jack Hayward Apr 12 at 13:43
1

Thanks Jack for pointing in right direction, I also faced same issue and after closing all above processes it was not working for me, so I looked into all processes Listening to ":443" port and closed those, after executing installation script again it worked for me.

You can execute "netstat" to get list of all process associated to specific port. Eg:

 netstat -aon | find ":443"
 netstat -aon | find ":80"

Referenced from Scott's Blog

0

So after trying all of the above, I finally tried something that seemed to work (I've since done 3 installations and have restarted without performing any of the "fix" steps and done yet another successful installation. So it's safe to say it is now working, but it's near impossible for me to track down exactly what the issue was here.

On the final attempt I did the following:

  • Restart
  • Ended all Sitecore related processes
  • Ended all COM Surrogate processes
  • Ended all processes that I knew I could close (Skype, Spotify etc)
  • Ended all services relating to any of the above (obviously keeping Solr running)

This seems to have fixed my issue, I'm sorry I couldn't provide more information on exactly what the cause was but hopefully this extensive list of attempts will be of some use to somebody in the future, let me know if you have any further questions.

0

Sitecore xconnect installs a service bound to an exe in the web installation folder, called .xconnect-ProcessingEngineService.

I killed the "xconnectsearchindexer.exe" process and was able to delete. I then removed the service itself, using PS 6.0 "Remove-Service"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.