1

Environment: Sitecore 9.0.2 XP0 + SXA 1.8.0 + Azure search

What I have done: My data is indexed in the index of Azure Search. I have added the search box and search result with custom scope 'locationSearch' on both the search box and the search result renderings.

I have created a rendering for the search result to display the field values.

I tried using the word 'test' and the values are getting listed.

Then I tried the word 'Canada' and I got the message configured for no result on my portal. When I copied the query from the log file and tried it in the azure search console, I received 2 items in response.

The items received in response has the fields mapped in the renderings.

Query in the log file:

&search=(language_1:(en) AND sxacontent:(/.canada./))&$filter=(latestversion_1 and (path_1/any(t:t eq '89395d52f7e84c37b5d6d027f1815bc5')) and searchable)&queryType=full&$skip=0&$top=20&$count=true

My question:

  1. Why there is this difference in response on my site and azure portal.
  2. What is the impact of scope, if I apply scope on both the renderings 'Search box' and 'Search result'.

Edit on 16th April: I added one of the scopes to the page item and saved it. Then I removed the scope and saved it again. After this, I was able to get the results on my portal. I will keep on adding, once I get something.

  • What does the content search query look like in your code? Also, have you read the limitations here: doc.sitecore.com/developers/91/… – Justin Bradley Apr 13 at 4:21
  • @JustinBradley: I am using the inbuilt code provided with SXA. Yes, I have checked those limitations. – NutsAndBolts Apr 13 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.