-1

enter image description here

When i activate the Marketing automation campaigns this error appear

"The requested resource was not found."

This issue appears after an upgrade from Sitecore 9.0 to 9.1. I compared the configs and dlls with a clean instance and they all the same.

  • Is there any Sitecore error logs .? – Gobinath Saminathan Apr 18 '19 at 18:27
  • Also you migrated from Sitecore 9.0 to 9.1 and looks like you verified the config files. Did you check the DB as well, there are few DB scripts which you might have executed to upgrade the xConnect, verify that as well. – Gobinath Saminathan Apr 18 '19 at 18:33
  • there is no errors in the log also i execute all the upgrade scripts but i will do it again – alaa Apr 21 '19 at 10:47
  • are you trying this in a distributed environment.? explain further about the how these are setup. – Gobinath Saminathan Apr 22 '19 at 13:44
  • Had a similar issue, check if all Activity Types have an Icon assigned. /sitecore/system/settings/Analytics/Marketing Automation/Activity Types/Campaign Entry – Mark Lowe Apr 23 '19 at 11:07
0

I have also experienced that the initial POST request works but but the following PUT and PATCH requests fails with 404 NotFound. The AutomationPlansController in Sitecore.Marketing.Automation.Client uses AutomationPlanRepository to find the plan, and if it is not found 404 is returned. The result is that if there is anything wrong with xConnect or SolR connection or schema, marketing definitions, etc., we will get this 404 error and there aren't really any usefull log entries.

I had errors in SolR and a custom computed field, I could see that in the Crawling log but not while this method failed. When the error was fixed I could repopulate SolR schema and depoloy market definitions, then the save and update operations worked.

Also note that those endpoints requires that you have runAllManagedModulesForAllRequests enabled in your web.config (we usually disable that for increased performance:

<modules runAllManagedModulesForAllRequests="true">
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.