5

This is using Sitecore 8.1 Update 1. When I click the search icon to get the "navigate to item" and search for something in my website, I get a "requested document not found" error. It's quite clearly there, but even something like my home page will throw this error. It's a multi-site setup, but I thought this was supposed to handle that just fine and even facilitate working in multiple sites.

This message is at the bottom of the page - "If the page you are trying to display exists, please check that an appropriate prefix has been added to the IgnoreUrlPrefixes setting in the web.config." - but I'd guess that's for any "real" pages - these are definitely Sitecore items.

Any thoughts? Thanks.

enter image description here enter image description here

  • Is there anything related to this in the logs? – Thomas D Sep 27 '16 at 13:30
  • 1
    Can you also post a screen shot? – Pete Navarra Sep 27 '16 at 13:31
  • Have you build your lucene indexes at least once? Do you see any errors on logs? would be helpful if you provide more details – Diego Sep 27 '16 at 14:04
  • I posted the screenshots as requested. I looked at the logs, I see where the search was executed, but I don't see anything around the result click. Yes, I built the indexes at least once...I see an update in sitecore_master_index at 8:45 am (the last edit I made). – Ken McAndrew Sep 27 '16 at 14:59
1

It looks like the problem is related to the item you are trying to open. For example in the screenshot you posted it is trying to open a page /acli/members/home I'm assuming that if you try to open that page on the browser it will throw the same error. can you confirm that? if that is the case I think this is your root cause. Your site acli_members does it reach those items you see on the results? maybe the site definition + the items path is throwing a 404 so what I would do is try to make sure that with the acli_members site you can open the items that are throwing this error i.e. http://myacli_membershost/acli/members/home should be resolved

| improve this answer | |
  • The /sitecore/content/acli/members and /home are set as the site root bits in the site definition, and I'm logged into the appropriate site. I've actually escalated this to Sitecore support...they said they weren't running into the issue, but it's definitely happening. I might end up trying to spin up a new site and put things in piece by piece, see if I can find the root cause. – Ken McAndrew Oct 5 '16 at 23:54
  • right but when you try to open: myacli_membershost/acli/members/home does it resolve to the acli_members site? what may be happening is that it is resolving to another site instead of acli_members which would be the reason why it's throwing 404 – Diego Oct 6 '16 at 12:51
  • It is resolving to acli_members. I actually heard back from Sitecore and they sent me another patch to try out...after I sent them a Fiddler trace they were able to duplicate my issue. – Ken McAndrew Oct 6 '16 at 15:23
  • 1
    ok please keep us posted on the outcome! – Diego Oct 6 '16 at 16:30
  • The patch that Sitecore sent worked - 81234, if you ever need to request it. – Ken McAndrew Oct 13 '16 at 15:29
0

Turns out to be a known Sitecore bug - request patch 81234 for a DLL/config from support.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.