0

I am working on an upgrade from SC 7.2 -> SC 9.1.1. First I used the Express Migration Tool to upgrade from 7.2 -> 9.0. Then I did a manual upgrade from 9.0 -> 9.1.1. Now I am seeing the following errors in the log file and I don't really understand what these mean. Can anyone help me understand what this error is and how I can fix it?

80004 10:15:50 ERROR Exception when executing agent aggregation/pathAnalyzerLiveAgent

Exception: Sitecore.XConnect.Client.XdbModelConflictException Message: One or more local models conflict with the xDB service layer. 'Sitecore.XConnect.ContentTesting.Model, 1.2' does not have a remote version, 'Sitecore.EmailCampaign.XConnectModel, 1.0' does not have a remote version

Source: Sitecore.Xdb.Common.Web at Sitecore.Xdb.Common.Web.Synchronous.SynchronousExtensions.SuspendContextLock[TResult](Func1 taskFactory) at Sitecore.XConnect.Client.XConnectSynchronousExtensions.SuspendContextLock(Func1 taskFactory) at Sitecore.XConnect.Client.Configuration.SitecoreXConnectClientConfiguration.Initialize(XmlNode configNode) at Sitecore.Configuration.DefaultFactory.CreateObject(XmlNode configNode, String[] parameters, Boolean assert, IFactoryHelper helper) at Sitecore.Configuration.DefaultFactory.CreateObject(XmlNode configNode, String[] parameters, Boolean assert) at Sitecore.Configuration.DefaultFactory.CreateObject(String configPath, String[] parameters, Boolean assert) at Sitecore.XConnect.Client.Configuration.SitecoreXConnectClientConfiguration.GetClient(String clientConfigPath) at Sitecore.Analytics.Aggregation.XConnect.DefaultXdbContextFactory.CreateReadOnly() at Sitecore.PathAnalyzer.Processing.Agents.TreeAggregatorAgent.Execute() at Sitecore.Analytics.Core.BackgroundService.Run()

  • Did you build the Path Analyzer maps after upgrade ? – Amitabh Vyas Apr 26 '19 at 17:23
  • No, that was not in the list of steps that I had to do after upgrading from 9.0 -> 9.1.1 – Corey Burnett Apr 26 '19 at 17:35
2

You received this error because you json models were not updated to 9.1.1 versions.

Sitecore 9.0 does not have any email campaign model, EXM was part of the platform starting with 9.0.1.

Please check in your updated solution if you have next models :

1.Sitecore.XConnect.ContentTesting.Model, 1.2.json

2.Sitecore.EmailCampaign.XConnectModel, 1.0.json

3.Sitecore.XConnect.Collection.ContactMerge.Model, 1.0.json

4.Sitecore.XConnect.Collection.Model, 9.0.json

enter image description here

|improve this answer|||||
  • I have the following models in that location: Sitecore.XConnect.Collection.Model, 9.0.json and Sitecore.XConnect.ContentTesting.Model, 1.0.json. Just those two. – Corey Burnett Apr 27 '19 at 16:20
  • please copy the other ones from a clean xconnect instalation. – Vlad Iobagiu Apr 27 '19 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.