0

I am trying to install Sitecore XC09 with SQL Server 2016 running on a separate server. The script terminates with the attached error.

I am running the Deploy-Sitecore-Commerce.ps1 provided in the sitecore commerce bundle.

Restarting SQL Server Something went wrong restarting SQL server again Install-SitecoreConfiguration : Cannot validate argument on parameter 'InputObject'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again. At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Install-SitecoreConfiguration.ps1:641 char:25 + & $entry.Task.Command @paramSet | Out-Default + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:14 Install-SitecoreConfiguration : Cannot validate argument on parameter 'InputObject'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again. At C:\sitecorecommerce\SIF\Deploy-Sitecore-Commerce.ps1:80 char:2 + Install-SitecoreConfiguration @params + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:01:05 Invoke-ManageCommerceServiceTask : Cannot validate argument on parameter 'InputObject'. The argument is null or empty. Provide an argument that is not null or empty, and then try the command again. At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Install-SitecoreConfiguration.ps1:641 char:25 + & $entry.Task.Command @paramSet | Out-Default + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-ManageCommerceServiceTask

Error Details : It says "Something went wrong restarting SQL Server again" and gives the error stack as shown in image above.

  • I found the solution to above problem, this problem occurs when you re-run the commerce installation script. Before re-running you need to delete all Website, Application Pools and Folders in wwwroot folder of Sitecore Commerce 9 update 2. – sharangs May 5 at 0:44
1

Sometimes SQL Server Windows service cannot restart after stopping, ensure SQL Server Window service is running.

Also please make sure that TCP/IP protocol is enabled for the SQL server.

https://www.habaneroconsulting.com/stories/insights/2015/tcpip-is-disabled-by-default-in-microsoft-sql-server-2014

enter image description here

  • I am still getting the same error, the above solution did not work for me. – sharangs May 3 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.