2

We’ve configured Sitecore schedule task, which runs at every 1 hour. The schedule task is running fine after deployment/web app restart but after sometime it’s not working as expected.

We’ve verified below points:

  1. Database agent is configured for the master database (yes, it’s)
  2. Sitecore.Pipelines.Loader.InitializeScheduler pipeline processor isn’t deleted with custom patch file (no, it’s not)
  3. INFO entries for the Scheduler - Adding agents in the Sitecore log file (yes, it’s)
  4. Application pool not cycled down (no, it’s not. Checked Sitecore logs and verified the keepalive.aspx url hitting at the specified interval (10 minutes) by UrlAgent)
  5. Verified the Sitecore schedule task’s schedule value (it’s 20160101|99990101|127|01:00:00)

Additional Notes:

Can anyone please help me?

  • Do you have more than on CM Server in scaled environment setup.? – Gobinath Saminathan Apr 30 '19 at 19:02
  • @Gobinath - No, we are having single CM server. – Bhavesh Maniya May 1 '19 at 5:54
  • @BhaveshManiya: Did you find something? Is it necessary to have it as async in Azure XP? – NutsAndBolts Aug 8 '19 at 8:51
  • @NutsAndBolts - Sorry, was busy with lot many things. No, I haven’t found anything basically moved to different project. Regarding async option, it’s not necessary (please refer above Kiran Patil's blog) – Bhavesh Maniya Oct 3 '19 at 11:58
  • @BhaveshManiya Have you checked the frequency interval and Sitecore.Tasks.TaskDatabaseAgent interval you need to set value there. And if you are trying to publish something on this scheduler then you also need to check Sitecore.Tasks.PublishAgent interval. – Nikhil Kulkarni Dec 15 '19 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.