0

I am trying to install Sitecore 9.1 update 1 on my local window 10 Machine, But I am getting the below error during the PowerShell installation:

Install-SitecoreConfiguration : Unable to parse [ResolveCertificatePath(variable('XConnectSolr_Security.XConnect.CertificatePath'))] - 
Exception calling "Evaluate" with "2" argument(s): "The running command stopped because the preference variable "ErrorActionPreference" 
or common parameter is set to Stop: 
Unable to parse [joinpath(variable('XConnectSolr_Security.CertificateStore'), 
variable('XConnectSolr_Security.XConnect.CertificateThumbprint'))] - Exception calling "Evaluate" with "2" argument(s): "The running 
command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: 
Unable to parse 
[GetCertificateThumbprint(parameter('XConnectSolr_XConnectCert'), variable('XConnectSolr_Security.CertificateStore'))] - Exception 
calling "InvokeWithContext" with "2" argument(s): "Cannot bind argument to parameter 'Id' because it is an empty string."""
At C:\Ashish\Sitecore\Software\Sitecore911\Install_new_instance.ps1:77 char:1
+ Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ...

 
  • which SIF version are you using? – Vlad Iobagiu May 2 at 17:19
  • 3
    2.1.0 which is required for Sitecore 9.1 update 1 – Ashish Bansal May 2 at 18:33
1

Make sure you are using the right SIF version, which in this case is 2.0.0.

The following command will show you your current version:

Get-Command -Module SitecoreInstallFramework | Select-Object -Property name, version

If you are still using SIF 1.2.1 you just need to upgrade it using the following commands:

To list all installed SIF versions

Get-InstalledModule -Name SitecoreInstallFramework -AllVersions

If you already have SIF 2.0.0 installed, you just need to set it as the current used version

Remove-Module -Name SitecoreInstallFramework
Import-Module -Name SitecoreInstallFramework -RequiredVersion 2.0.0

If you don't have SIF 2.0.0, then you must install it

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.0.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.