0

I am getting following error while Email Test Connection for EXM. "The email connection failed or the SMTP server could not verify the username and password."

I setup SMTP in Sitecore.EDS.Providers.CustomSmtp.config but still getting this error, am i missing something here?

Please help.

<smtpSettings type="Sitecore.EDS.Core.Net.Smtp.SmtpSettings, Sitecore.EDS.Core" singleInstance="true">
                  <server>XXXXXXXX</server>
              <port>587</port>
              <loginDomain>XXXXX</loginDomain>
              <userName>XXXXXXXX</userName>
              <password>XXXXXXXXX</password>
              <authenticationMethod>NTLM</authenticationMethod>
              <startTls>false</startTls>
              <proxySettings ref="exm/eds/proxySettings" />
                </smtpSettings>
2

When setting up the EXM SMTP Provider, there are a handful of settings you need to make sure are correct.

The error you have posted is indicating that that there is something wrong with the credentials that you have configured.

Either your password is wrong, your username is wrong, or your login authenticationMethod setting is wrong.

I would also make sure you have enabled the CustomSMTP setting in the eds:define variable in the web.config.

For a full run down of EXM Custom SMTP settings and a walk through on how to set it up visit https://sitecorehacker.com/2018/12/04/configuring-customsmtp-settings-in-exm/

| improve this answer | |
1

It seems like your credential is not correct. Can you please try with gmail credential for testing with below settings?

 <smtpSettings type="Sitecore.EDS.Core.Net.Smtp.SmtpSettings, Sitecore.EDS.Core" singleInstance="true">
          <server>smtp.gmail.com</server>
          <port>587</port>
          <userName>XXX.XXX@gmail.com</userName>
          <password>XXXX</password>
          <authenticationMethod>LOGIN</authenticationMethod>
          <startTls>true</startTls>
          <proxySettings ref="exm/eds/proxySettings" />
        </smtpSettings>
| improve this answer | |
0

In my case smtp server was disabled in control panel. I had to enable the smtp server for my gmail account.

You can check these setting using cmd

`ping smtp.gmail.com` 

disabled:

Request timed out.

enabled (https://www.questionmark.com/content/adv14-configure-smtp-service)

Reply from xx.xx.xx.xx: bytes=32 time=8ms TTL=42
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.