On Sitecore 9.0.2 on-premise we want to scale out the xConnect Collection and Collection Search Service.

According to documentation we need to perform steps mentioned below to achieve that:

  1. We need to introduce xconnect.collection.search and xconnect.collection.search.certificate in the connectionstring.config.
  2. Then we need to edit the \App_Config\Sitecore\XConnect.Client.Configuration\Sitecore.XConnect.Client.config file and update the searchConnectionStringName to the new entry in connectionstring.config on every core role that requires access to the xConnect Search service in our case its CM and CDs.

But it is not quite clear in the documentation that where we need to update configuration for the xconnect.collection.search.certificate or just adding it to the connectionstring.config will suffice?

2 Answers 2


Did you do an install using SIF (Sitecore Install Framework)? If you did you'll find in your AppSettings.config within the Sitecore xConnectSearch site a setting for validateCertificateThumbprint. This value is used in your CM and CD (Also I think the Reporting site as well) in the connectionstrings.config and must reference the same thumbprint.

  <!-- YOUR XConnect Search URL-->
  <add name="xconnect.collection" connectionString="https://www.xconnectSearchURL.com" />
  <!-- YOUR XConnect Search Certificate-->
  <add name="xconnect.collection.certificate" connectionString="StoreName=My;StoreLocation=LocalMachine;FindType=FindByThumbprint;FindValue=HEREGOESTHETHUMBPRINT" />

That thumbprint is from a cert that was generated during the SIF install. If you want to use in house generated certificates make sure the cert can be used as a client cert, can be found under Enhanced Key Usage from MMC.

Sitecore has some documentation here but I've found it easiest to do a full scale install locally and reference the connectionstrings from the CM site.

Hope this helps, Ty

  • Thanks Tyler but my question is different. Yes I installed using SIF but OOTB CM/CD/PRC/REP doesn't have separate connection string for Collection Search. What all you have is just Collection, Marketing Automation, Marketing Reporting and xDB Reference Data. I want to add a new connection string dedicated for Collection Search to scale out. May 9, 2019 at 19:33
  • Oh gotcha, sorry read that wrong. You'd be more looking into changing the searchConnectionStringName and other settings in the Sitecore.XConnect.Client.config file (App_Config\Sitecore\XConnect.Client.Configuration). Pretty sure you'd need to make similar changes in your EXM (If seperated from CM), Marketing Automations, and xDB Processing.
    – Tyler.S
    May 9, 2019 at 19:53

As Tyler said first of all we definitely need to install two dedicated instances for xConnect Collection and xConnect Collection Search. Make sure both are up and running using valid certificates.

Then modify \App_Config\Sitecore\XConnect.Client.Configuration\Sitecore.XConnect.Client.configon Content Management, Content Delivery (Also Processing and Reporting if those are scaled). In this config both collectionConnectionStringName and searchConnectionStringName have the same value OOTB as xconnect.collection. Update a different value for searchConnectionStringName (we used xconnect.search).

enter image description here

Now in \App_Config\ConnectionStrings.config on Content Management, Content Delivery (Also Processing and Reporting if those are scaled), we need to add a new connection string for xconnect.search. This should point to your xConnect Collection Search instance and obviously like others you need to provide the valid certificate thumbprint which should match with the thumbprint mentioned in \App_Config\AppSettings.config on xConnect Collection Search instance.

So we were confused about the configuration changes to add the new setting for xConnect Collection Search Thumbprint in connectionstring.config. Hence it must be the value we used for searchConnectionStringName concatenated with ".certificate". In our case it is xconnect.search.certificate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.