I've installed JSS 11.0.0 onto Sitecore 9.1.


enter image description here

I have added API key as mentioned here: https://medium.com/infocentric/how-to-setup-javascript-services-jss-for-sitecore-9-7e54893c64d8 .

enter image description here

Now i want to verify my installation, but when i am running URL getting below response:

enter image description here

Please suggest, what i am missing?

How to verify JSS 11.0.0 installation onto sitecore 9.1?


WARN [Sitecore Services]: API key {A81EE064-F9A1-4719-A7A1-279C8B20CAFB} is not found.


2 Answers 2


Fix is bit small but i want to specified so no one else again face this issue. After setup API key to master DB, publish this item.

Now when i am running URL it's giving response.

enter image description here


For Sitecore 9.1 you should not create the API key in Core DB [I mean the link you referred above is for previous version of Sitecore], You have to create the API key in master DB under the path /sitecore/system/Settings/Services/API Keys

If you don't have the site setup then look at your default site in Sitecore.config, if the database is "web" then you need to publish the API key to work.

<site name="website" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content" startItem="/home" language="en" database="web"../>

If you already have the app setup, Check your entry in JSS application config located in "\Website\App_Config\Include\yourappname.config", if the database is "web" then you need to publish the API key. If it is "master" you actually no need to publish and it will read the content from master context.

<site patch:before="site[@name='website']"
            database="web" />
  • i created key on master DB only. i missed publish this item. ;( May 13, 2019 at 13:47
  • okay.. it actually works based on the context DB, so the context DB in your case might be web. May 13, 2019 at 13:48
  • Yes Gobinath. Anyway issue is fix. Happy learning. May 13, 2019 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.