1

Consider the following scenario, Sitecore 8.0 rev5

/sitecore/content/mysite/clone-test/source/  
/sitecore/content/mysite/clone-test/clones/  

Clone the "source" item into the clones folder, so we end up with:

/sitecore/content/mysite/clone-test/clones/clone-of-source1  
/sitecore/content/mysite/clone-test/clones/clone-of-source2  
/sitecore/content/mysite/clone-test/clones/clone-of-source3  

The clones page loops through its children and displays all of their short descriptions

@foreach (var item in items)
{
  <p>@item.Fields["Short Description"].Value</p>
}

Is anyone aware of a bug in the cloning mechanism related to retrieving source values? We're having some issues with the following procedure:

On /sitecore/content/mysite/source, add a value (previously blank) to its short description field (multiline text box) and publish.

Expected behavior:
All clones of source (clone-of-source1, etc) should now be showing the updated "Short Description" value from the source

Actual behavior
All clones of source are still displaying an empty value


Update: These templates are inheriting from a base template. Only fields from the base template are not populating.

Update 2: It seems like the only time it works is if there is a default value in the field of the clone source before the clone happens. If it's blank, we don't get the "original value" label next to it, but if it has a value, we do.

Update 3: Behavior only exists when cloning a branch template. I tested with regular templates and it worked fine.

I simplified this to forgo the for-loop and just displayed the value of the item on its rendering, but still no luck.

6
  • It looks you break the inheritance of cloned items by updating any specific field value. When you update specific field value manually for any cloned item, that field will not inherit the value from original item.
    – S.Kazmi
    May 14, 2019 at 1:38
  • But we're not changing anything on the clone, only the source, so inheritance shouldn't be broken. We clone the item, then change the source, the cloned item should inherit the updated value.
    – tjans
    May 14, 2019 at 12:26
  • There are current bugs related to Branch Items and items created on the basis of Branch Items that I suspect could be the root cause of your problem here. Unfortunately your only option would be to go to Sitecore Support for a fix.
    – Mark Cassidy
    May 15, 2019 at 16:42
  • Thanks for your response, Mark. Unfortunately we're on 8.0 and thus it's no longer supported by Sitecore. We are upgrading to 9 in Q3. Thus, I can't really use that as a solution right now, unfortunately.
    – tjans
    May 15, 2019 at 21:10
  • Indeed. Well if the problem IS related to my suspicion, upgrading won't help you - the problem still exists in 9.1.1 even. It would require a fair bit of workaround in the way clones are handled.
    – Mark Cassidy
    May 16, 2019 at 6:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.