0

I have upgraded Sitecore 8.1 to 9.1 and now in 9.1 PDF items are not getting indexed and also they are not getting listed in a multilist with search field.

closed as too broad by Marek Musielak, Mark Cassidy May 23 at 9:17

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you include pdf template in index file? What is a root path of index? – Swati Gupta May 14 at 6:55
  • Which index are you using? Azure/Solr,? And which one were you using on 8.1? – Gatogordo May 14 at 9:18
  • currently solr and with 8.1 Lucene – user5506 May 14 at 9:19
1

Sounds like you are missing the needed IFilter to index pdf content. Check https://doc.sitecore.com/developers/91/platform-administration-and-architecture/en/index-pdf-files.html for the information on 9.1:

The Sitecore Content Search API uses the native Microsoft Windows IFilter interface to extract the text content from media files for indexing.

However, to enable the Sitecore Content Search API to properly index the content in Adobe PDF files, you must install the Adobe PDF IFilter on every content management and content delivery server.

Currently, Sitecore only supports Adobe PDF IFilter version 9.

You can install Adobe PDF IFilter as a standalone IFilter or as part of Adobe Acrobat Reader. You can download Adobe PDF IFilter version 9 from ftp://ftp.adobe.com/pub/adobe/acrobat/win/9.x/.

Not the answer you're looking for? Browse other questions tagged or ask your own question.