0

I am trying to install Sitecore Experience platform 9.0 using Sitecore via SIF.

Versions of the pre-requisite Softwares/Tools are

  • SQL Server Version-14.0.1000.169,
  • Sitecore XP 9.0,
  • Solr-6.6.2,
  • SIF 1.2

During Install WDP : WebDeploy step, I am facing ERROR_SCRIPTDOM_NEEDED_FOR_SQL_PROVIDER error and couldn't proceed with further installation.

I have followed every step that was mentioned in this article https://naveed-ahmad.com/2017/11/03/sitecore-9-sif-installation-error-error_scriptdom_needed_for_sql_provider/ , but still issue continues.Thanks in advance! enter image description here

  • Did you try installing it with another instance name? once you fail anything you have to clean everything before starting the installation setup. – Sitecore Sam May 20 '19 at 6:01
  • I haven't renamed so far. Will do that and try. Thanks for the help @SitecoreSam. – srikargvs May 20 '19 at 6:04
  • Tried renaming it and executed. Issue still persists @SitecoreSam. – srikargvs May 20 '19 at 6:08
  • did you check you have all the windows features enabled required for the installation setup. Take a look at my article it has saved so many developers time, isaadansari.wordpress.com/2018/05/01/… – Sitecore Sam May 20 '19 at 7:11
0

If you have already installed all the prerequisite then make sure that you have added missing registry DacFxPath and DacFxDependenciesPath under the registry key \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IIS Extensions\MSDeploy\3

Follow article https://kb.sitecore.net/articles/019579

Key - DacFxPath

Value - C:\Program Files\Microsoft SQL Server\140\DAC\bin

Key – DacFxDependenciesPath

Value - C:\Program Files\Microsoft SQL Server\140\DAC\bin

Note- Please clean everything before executing the installation script again

| improve this answer | |
  • Thanks a lot.It worked after changing the registry entries as mentioned. – srikargvs May 20 '19 at 9:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.