4

I have installed Sitecore 9.1.0 XP on my system with Solr 7.2.1.

I want to install Sitecore 9.0.1 XP also on my system. Should I use Solr 7.2.1 for this or do I need Solr 6.6.2?

Any help is appreciated.

5

Solr 7.2.1 is not supported by Sitecore 9.0.1 officially.

But does it mean Sitecore 9.0.1 will not work with Solr 7.2.1? No, it doesn't. It means that Sitecore 9.0.1 is not officially tested against that version. And it means that if you will use Solr 7.2.1 with Sitecore 9.0.1 and you experience any issues, Sitecore Support will be allowed to tell you "Sorry, but you're using unsupported version of Solr".

I know about plenty of projects running on newer Solr versions than are supported officially and they do work well.

So should you use 7.2.1 for your second project or install 6.6.2? One good answer does not exist.

And here is the compatibilitya fragment of table which is mentioned by @Anton in his answer (table copied from the Sitecore documentation site):

enter image description here

https://kb.sitecore.net/articles/227897

2

I suggest to install Solr 6.6.2 on you local system and run it on different port.

Solr 6.6.2 is compatible with Sitecore 9.0.1 XP and it will not break other Sitecore instances on your env.

1

It is not officially supported. Use this table to check.

However, if it for you local instance you can use it. For example I have different version of Sitecore, but only 1 version of Solr. But don't do it on servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.