Because of the 1000 leaf limit in azure search I had to set index all fields to false. Now I don't see any forms on the dashboard of the Sitecore 9.1 forms app.

enter image description here

I have tried including the forms template in my patch config

enter image description here

and tried including Is Template as an included field (based on another sse post I found).

/sitecore/templates/System/Forms/Form/Settings/Is Template

I tried rebuilding the sitecore_master_index, and the SXA master and web indexes too. There are no errors logged in the Sitecore log and no errors in the console.

Note: I am getting search results as expected and was previously seeing the forms on the dashboard so it does seem like they're no longer in the index, just not sure what I've missed to include them again.

Update: Have removed the included template line from my config as my sitecore_master_index suddenly only had 2 documents in it after rebuilding (which were the forms so not sure why they weren't appearing on the dashboard). It obviously does not work as I expected it would.

My patch config looks like this: enter image description here

  • Did you try this sitecore.stackexchange.com/a/13030/1278 May 28, 2019 at 7:28
  • @MarkGibbons thanks for that - that's the same answer sitecore support gave, so am back in action. I did not find that yesterday when googling.
    – Jen
    May 29, 2019 at 4:29

1 Answer 1


The flag indexAllFields will index all fields by default. This allows new fields in your templates to automatically be included into the index , we can change this option on below choices.

  1. Set this to true and place all the fields you would like to remove in the 'ExcludeField' list below.
  2. Set to false and place all fields you would like to be indexed in the 'IncludeField' list below.

While making this false it improves the performance by only indexing the required fields that it needs. But Sitecore Forms are not getting index automatically as a result those are not appearing on the dashboard .

Try to add the GUID ID of the IS Template field in your Solr Default Index Configuration file or adding a patch file like below

<include hint="list:AddIncludedField">

In content editor select the Form go to the developer toolbar in sitecore ribbon and click to re-index tree. After doing that if forms doesn't display on the dash board then please check in search log text file if any other issues are causing or not.

If you find the error in search log like "undefined field is_template" then there please refer the link to get the solutions .

Not the answer you're looking for? Browse other questions tagged or ask your own question.